Permalink
Browse files

build: Require notify-sharp-3.0 and clean up configure checks

Now that notify-sharp has a 3.0 release that depends on GTK 3, we can
require the proper pkg-config module.

Remove notify-sharp.m4 file, and the useless call to the macro that was
defined in it.

Also remove some unneeded variables in build.environment.mk.
  • Loading branch information...
bl8 committed Nov 4, 2013
1 parent aa6b8bc commit 6183627f0825b9901eae7e3a96ef14cf48a754f8
Showing with 2 additions and 25 deletions.
  1. +0 −4 build/build.environment.mk
  2. +0 −12 build/m4/sparkleshare/notify-sharp.m4
  3. +2 −9 configure.ac
@@ -15,10 +15,6 @@ LINK_GNOME = $(GNOME_SHARP_LIBS)
LINK_WEBKIT = $(WEBKITGTK_SHARP_LIBS)
LINK_APP_INDICATOR = $(APP_INDICATOR_LIBS)
-REF_NOTIFY_SHARP = $(LINK_SYSTEM) $(LINK_DBUS) $(GTKSHARP_LIBS) $(GLIBSHARP_LIBS)
-LINK_NOTIFY_SHARP = -r:$(DIR_BIN)/NotifySharp.dll
-LINK_NOTIFY_SHARP_DEPS = $(REF_NOTIFY_SHARP) $(LINK_NOTIFY_SHARP)
-
REF_SPARKLELIB = $(LINK_SYSTEM) $(LINK_MONO_POSIX)
LINK_SPARKLELIB = -r:$(DIR_BIN)/SparkleLib.dll
LINK_SPARKLELIB_DEPS = $(REF_SPARKLELIB) $(LINK_SPARKLELIB)
@@ -1,12 +0,0 @@
-AC_DEFUN([SPARKLESHARE_CHECK_NOTIFY_SHARP],
-[
- PKG_CHECK_MODULES(NOTIFY_SHARP, notify-sharp, have_notify_sharp=yes, have_notify_sharp=no)
- if test "x$have_notify_sharp" = "xyes"; then
- AC_SUBST(NOTIFY_SHARP_LIBS)
- AM_CONDITIONAL(EXTERNAL_NOTIFY_SHARP, true)
- else
- AM_CONDITIONAL(EXTERNAL_NOTIFY_SHARP, false)
- AC_MSG_RESULT([no])
- fi
-])
-
View
@@ -34,8 +34,6 @@ SHAMROCK_CHECK_MONO_4_0_GAC_ASSEMBLIES([
])]
)
-SPARKLESHARE_CHECK_NOTIFY_SHARP
-
AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug],
[Use 'DEBUG' Configuration [default=YES]]),
@@ -66,20 +64,15 @@ OSNAME=`uname -s`
if test "$OSNAME" = "Linux" ; then
SPARKLESHARE_CHECK_GTK_SHARP
+ PKG_CHECK_MODULES(NOTIFY_SHARP, notify-sharp-3.0)
+
dnl check for webkitgtk-sharp
PKG_CHECK_MODULES(WEBKITGTK_SHARP, webkitgtk-sharp-3.0, have_webkitgtk_sharp=yes, have_webkitgtk_sharp=no)
if test "x$have_webkitgtk_sharp" = "xno" ; then
AC_ERROR("webkitgtk-sharp is a required dependency: you need to install the appropriate devel package before you can compile")
fi
AC_SUBST(WEBKITGTK_SHARP_LIBS)
- dnl check for notify-sharp
- PKG_CHECK_MODULES(NOTIFY_SHARP, notify-sharp, have_notify_sharp=yes, have_notify_sharp=no)
- if test "x$have_notify_sharp" = "xno" ; then
- AC_ERROR("notify-sharp is a required dependency: you need to install the appropriate devel package before you can compile")
- fi
- AC_SUBST(NOTIFY_SHARP_LIBS)
-
APPINDICATOR_REQUIRED=0.1
if test x$enable_appindicator = xauto ; then

0 comments on commit 6183627

Please sign in to comment.