Skip to content

Sparkleshare looping the projects several times. #1130

Closed
unconscious opened this Issue Jan 2, 2013 · 18 comments

3 participants

@unconscious

Menu_003

That is what I get when I right click the sparkleshare icon in my ubuntu 12.04 gnome laptop.

Its not only in display. It queries the same repo several times every time it checks for changes. (Checked in logs.)

Recent changes has the same problem.

Screenshot from 2013-01-02 20:15:21

I only have 6 repos btw.

@hbons
Owner
hbons commented Jan 2, 2013

is this still the case if you restart SparkleShare?
did you make any changes in the SparkleShare folder when before this happened (like deleting a folder)?

@unconscious

Pretty sure it has something to do with this #1092

@unconscious

Restarting does the same.

No changes/deletions.

@unconscious

Loops are random. Could loop any number of times.

@hbons
Owner
hbons commented Jan 2, 2013

do the folders appear many times in ~/.config/sparkleshare/config.xml as well?

@unconscious

Config is proper. I checked that before posting.

@hbons hbons closed this in 037951b Jan 5, 2013
@hbons hbons reopened this Jan 5, 2013
@hbons
Owner
hbons commented Jan 5, 2013

can you give me a log of the startup process?

@hbons hbons referenced this issue Jan 10, 2013
Closed

Double entries #1148

@hbons
Owner
hbons commented Jan 13, 2013

@unconscious could you try to compile from current master and see if it fixed the problem?

@unconscious

The currect master doesn't even startup. Does nothing at all.

$:~/Downloads/SparkleShare-master$ sparkleshare restart
SparkleShare is not running, removing stale PID file...
Starting SparkleShare... Done.
$:~/Downloads/SparkleShare-master$ sparkleshare restart
SparkleShare is not running, removing stale PID file...
Starting SparkleShare... Done.

@hbons
Owner
hbons commented Jan 15, 2013

soemthing changed in the build system. if you run ./autogen.sh --prefix=/usr make, and sudo make install again it should work.

@unconscious

Nope. Same thing even after doing the above.

@hbons
Owner
hbons commented Jan 16, 2013

and now?

@unconscious

Still nothing.

I am running ./autogen.sh --prefix=/usr, make, and sudo make install just to be sure we are on the same page.

@hbons
Owner
hbons commented Jan 27, 2013

@unconscious it compiles fine here, and i've had several other people compile and run current master without a problem... can you remove the clone and try with a fresh one?

@unconscious

SparkleShare version: 1.1.0
Operating system: Unix Unix 3.2.0.36
System.IO.IOException: Win32 IO returned ERROR_ALREADY_EXISTS. Path:
at System.IO.File.Move (System.String sourceFileName, System.String destFileName) [0x00000] in :0
at SparkleShare.SparkleControllerBase.Initialize () [0x00000] in :0
at SparkleShare.Program.Main (System.String[] args) [0x00000] in :0

@hbons
Owner
hbons commented Feb 13, 2013

@unconcious thanks. that should be fixed by the commit in #1184 now.

@yusf
yusf commented Feb 26, 2013

Confirming this for 1.0 on Mac OS X 10.8.2. config.xml is okay.

Ska rmavbild 2013-02-26 kl 15 59 08

@hbons
Owner
hbons commented May 29, 2013

does this still happen with 1.1?

@hbons hbons closed this Jun 22, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.