SparkleShare is missing an icon in the GNOME 3 system tray #252

Closed
garrett opened this Issue Jun 25, 2011 · 16 comments

Comments

Projects
None yet
8 participants
@garrett
Contributor

garrett commented Jun 25, 2011

SparkleShare is missing an icon in the GNOME 3 system tray, at least when I build it on openSUSE 11.4

@yafp

This comment has been minimized.

Show comment
Hide comment
@yafp

yafp Jun 27, 2011

Contributor

@garrett:
sparkleshare 0.2.2 acts like dropbox on my ubuntu/gnome 3 test-box.

in short:
no menu-icon in the default upper-bar ...but a non-default looking icon in the lower notification area.

I guess you are talking about the upper menubar/system-tray right?

Contributor

yafp commented Jun 27, 2011

@garrett:
sparkleshare 0.2.2 acts like dropbox on my ubuntu/gnome 3 test-box.

in short:
no menu-icon in the default upper-bar ...but a non-default looking icon in the lower notification area.

I guess you are talking about the upper menubar/system-tray right?

@garrett

This comment has been minimized.

Show comment
Hide comment
@garrett

garrett Jun 27, 2011

Contributor

Nope, I'm talking about the bottom-right corner. There's a poorly scaled generic "graphic" icon instead of the SparkleShare icon.

Contributor

garrett commented Jun 27, 2011

Nope, I'm talking about the bottom-right corner. There's a poorly scaled generic "graphic" icon instead of the SparkleShare icon.

@yafp

This comment has been minimized.

Show comment
Hide comment
@yafp

yafp Jun 27, 2011

Contributor

ack - got that too.

Contributor

yafp commented Jun 27, 2011

ack - got that too.

@hbons

This comment has been minimized.

Show comment
Hide comment
@hbons

hbons Jun 27, 2011

Owner

@garrett probably an icon install issue? it gets the icon from /usr/share/sparkleshare/icons/*/process-syncing-sparkleshare

Owner

hbons commented Jun 27, 2011

@garrett probably an icon install issue? it gets the icon from /usr/share/sparkleshare/icons/*/process-syncing-sparkleshare

@garrett

This comment has been minimized.

Show comment
Hide comment
@garrett

garrett Jun 27, 2011

Contributor

ls /usr/share/sparkleshare
ls: cannot access /usr/share/sparkleshare: No such file or directory

ls /usr/local/share/sparkleshare
html icons pixmaps

Contributor

garrett commented Jun 27, 2011

ls /usr/share/sparkleshare
ls: cannot access /usr/share/sparkleshare: No such file or directory

ls /usr/local/share/sparkleshare
html icons pixmaps

@garrett

This comment has been minimized.

Show comment
Hide comment
@garrett

garrett Jun 27, 2011

Contributor

(In other words, it should look in $PREFIX that it was installed into...)

Contributor

garrett commented Jun 27, 2011

(In other words, it should look in $PREFIX that it was installed into...)

@hbons

This comment has been minimized.

Show comment
Hide comment
@hbons

hbons Jun 27, 2011

Owner

but is the icon in there?

Owner

hbons commented Jun 27, 2011

but is the icon in there?

@petalogix

This comment has been minimized.

Show comment
Hide comment
@petalogix

petalogix Jun 30, 2011

Building and installing latest master on Ubuntu 11.04 I also don't get a system tray icon. /usr/local/sparkleshare is all present and accounted for, and the daemon is running fine.

Building and installing latest master on Ubuntu 11.04 I also don't get a system tray icon. /usr/local/sparkleshare is all present and accounted for, and the daemon is running fine.

@hbons

This comment has been minimized.

Show comment
Hide comment
@hbons

hbons Jun 30, 2011

Owner

@petalogix are you building with libappindicator devel files installed (see README)

Owner

hbons commented Jun 30, 2011

@petalogix are you building with libappindicator devel files installed (see README)

@petalogix

This comment has been minimized.

Show comment
Hide comment
@petalogix

petalogix Jun 30, 2011

@hbons my mistake - thanks.

@hbons my mistake - thanks.

@Flink

This comment has been minimized.

Show comment
Hide comment
@Flink

Flink Jul 5, 2011

Same as petalogix, I’m not getting a system tray icon but I installed with libappindicator though.

Flink commented Jul 5, 2011

Same as petalogix, I’m not getting a system tray icon but I installed with libappindicator though.

@garrett

This comment has been minimized.

Show comment
Hide comment
@garrett

garrett Jul 6, 2011

Contributor

I did try installing after running ./configure --prefix=/usr and I still do not have an icon in the tray. Also, I'm not using libappindicator (as I'm on openSUSE, not Ubuntu).

Contributor

garrett commented Jul 6, 2011

I did try installing after running ./configure --prefix=/usr and I still do not have an icon in the tray. Also, I'm not using libappindicator (as I'm on openSUSE, not Ubuntu).

@hbons hbons closed this Jul 29, 2011

@wimh wimh referenced this issue Dec 24, 2011

Closed

icon not displayed #494

@njoyard

This comment has been minimized.

Show comment
Hide comment
@njoyard

njoyard Nov 25, 2012

This issue is still present when building from source (used 0.9.8 tag on Ubuntu Gnome 12.10, built with libappindicator).
Might be covered by #957, though.

njoyard commented Nov 25, 2012

This issue is still present when building from source (used 0.9.8 tag on Ubuntu Gnome 12.10, built with libappindicator).
Might be covered by #957, though.

@g81009

This comment has been minimized.

Show comment
Hide comment
@g81009

g81009 Nov 27, 2012

Hello,
i just have the same problem with an missing icon on debian wheezy but only on one system. The other installation shows the icon, but this one has an other screen resolution.

g81009 commented Nov 27, 2012

Hello,
i just have the same problem with an missing icon on debian wheezy but only on one system. The other installation shows the icon, but this one has an other screen resolution.

@g81009

This comment has been minimized.

Show comment
Hide comment
@g81009

g81009 Nov 27, 2012

The icon is missing in gnome-classic-mode

g81009 commented Nov 27, 2012

The icon is missing in gnome-classic-mode

@jtbm37

This comment has been minimized.

Show comment
Hide comment
@jtbm37

jtbm37 Sep 22, 2013

Is this why I am getting these errors on startup on Fedora 19 ?
Gnome shell version = GNOME Shell 3.8.4

(SparkleShare:20538): GLib-GObject-WARNING **: gsignal.c:2475: signal child-added' is invalid for instance0x1df6820' of type `GtkMenu'

jtbm37 commented Sep 22, 2013

Is this why I am getting these errors on startup on Fedora 19 ?
Gnome shell version = GNOME Shell 3.8.4

(SparkleShare:20538): GLib-GObject-WARNING **: gsignal.c:2475: signal child-added' is invalid for instance0x1df6820' of type `GtkMenu'

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment