Skip to content
Browse files

Bumped version to 0.5.2. Also require pymc 2.3 and kabuki 0.5.2

  • Loading branch information...
1 parent 6b2c4a3 commit b561a7a5a021c12ef0858c8cfe5711cda0b8e2a5 @twiecki twiecki committed Nov 12, 2013
Showing with 12 additions and 12 deletions.
  1. +2 −2 .bumpversion.cfg
  2. +1 −1 README.rst
  3. +2 −2 docs/source/conf.py
  4. +1 −1 hddm/__init__.py
  5. +3 −3 meta.yaml
  6. +3 −3 setup.py
View
4 .bumpversion.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-files = README.rst docs/Makefile docs/make.py hddm/__init__.py .bumpversion.cfg
+files = README.rst docs/Makefile docs/make.py hddm/__init__.py .bumpversion.cfg meta.yaml setup.py
commit = True
tag = True
-current_version = 0.5.2.beta
+current_version = 0.5.2
View
2 README.rst
@@ -9,7 +9,7 @@ Introduction
:Mailing list: https://groups.google.com/group/hddm-users/
:Copyright: This document has been placed in the public domain.
:License: HDDM is released under the BSD 2 license.
-:Version: 0.5.1.dev
+:Version: 0.5.2
.. image:: https://secure.travis-ci.org/hddm-devs/hddm.png?branch=develop
View
4 docs/source/conf.py
@@ -68,9 +68,9 @@
# built documents.
#
# The short X.Y version.
-version = '0.5.2.beta'
+version = '0.5.2'
# The full version, including alpha/beta/rc tags.
-release = '0.5.2.beta'
+release = '0.5.2'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
View
2 hddm/__init__.py
@@ -2,7 +2,7 @@
__docformat__ = 'restructuredtext'
-__version__ = '0.5.2.beta'
+__version__ = '0.5.2'
import likelihoods
import generate
View
6 meta.yaml
@@ -1,12 +1,12 @@
package:
name: hddm # lower case name of package, may contain '-' but no spaces
- version: 0.5.1.dev # version of package
+ version: 0.5.2 # version of package
source:
# The source section specifies where the source code of the package is coming
# from, it may be coming from a source tarball like:
git_url: git@github.com:hddm-devs/hddm.git
- git_tag: develop # (optional)
+ git_tag: master # (optional)
# the build and runtime requirements:
requirements: # (optional)
@@ -39,4 +39,4 @@ test: # (optional)
about: # (optional)
home: https://ski.clps.brown.edu/hddm_docs/
- license: BSD
+ license: BSD
View
6 setup.py
@@ -18,16 +18,16 @@
setup(
name='HDDM',
- version='0.5.2.beta',
+ version='0.5.2',
author='Thomas V. Wiecki, Imri Sofer, Michael J. Frank',
author_email='thomas_wiecki@brown.edu',
url='http://github.com/hddm-devs/hddm',
packages=['hddm', 'hddm.tests', 'hddm.models', 'hddm.examples'],
package_data={'hddm':['examples/*.csv', 'examples/*.conf']},
scripts=['scripts/hddm_demo.py'],
description='HDDM is a python module that implements Hierarchical Bayesian estimation of Drift Diffusion Models.',
- install_requires=['NumPy >=1.6.0', 'SciPy >= 0.6.0', 'kabuki >= 0.5.2.beta', 'PyMC >= 2.2', 'pandas >= 0.10.0', 'patsy'],
- setup_requires=['NumPy >=1.6.0', 'SciPy >= 0.6.0', 'kabuki >= 0.5.2.beta', 'PyMC >= 2.2', 'pandas >= 0.10.0', 'patsy'],
+ install_requires=['NumPy >=1.6.0', 'SciPy >= 0.6.0', 'kabuki >= 0.5.2', 'PyMC == 2.3', 'pandas >= 0.10.0', 'patsy'],
+ setup_requires=['NumPy >=1.6.0', 'SciPy >= 0.6.0', 'kabuki >= 0.5.2', 'PyMC == 2.3', 'pandas >= 0.10.0', 'patsy'],
include_dirs = [np.get_include()],
classifiers=[
'Development Status :: 5 - Production/Stable',

0 comments on commit b561a7a

Please sign in to comment.
Something went wrong with that request. Please try again.