Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

BLD: Updated pymc requirement.

  • Loading branch information...
commit 7dd67670fb92f123515df2c26d8d662646da19cf 1 parent 43acf74
@twiecki twiecki authored
Showing with 4 additions and 4 deletions.
  1. +2 −2 kabuki/hierarchical.py
  2. +2 −2 setup.py
View
4 kabuki/hierarchical.py
@@ -1015,7 +1015,7 @@ def _approximate_map_subj(self, minimizer='Powell', use_basin=False, fall_to_sim
obs_nodes = self.nodes_db.ix[(self.nodes_db.subj_idx == subj_idx) & (self.nodes_db.observed == True)].node
self._partial_optimize(stoch_nodes, obs_nodes, fall_to_simplex=fall_to_simplex, minimizer=minimizer, use_basin=use_basin, debug=debug, minimizer_kwargs=minimizer_kwargs, basin_kwargs=basin_kwargs)
- def approximate_map(self, individual_subjs=True, minimizer='Powell', use_basin=False, fall_to_simplex=True, cycles=1, debug=False, minimizer_kwargs=None, basin_kwargs=None):
+ def approximate_map(self, individual_subjs=True, minimizer='Powell', use_basin=False, fall_to_simplex=True, cycles=1, debug=False, minimizer_kwargs=None, basin_kwargs=None, skip_generations=0):
"""Set model to its approximate MAP.
:Arguments:
@@ -1062,7 +1062,7 @@ def approximate_map(self, individual_subjs=True, minimizer='Powell', use_basin=F
if name in [node.__name__ for node in gen]])
for cyc in range(cycles):
- for i in range(len(generations)-1, 0, -1):
+ for i in range(len(generations)-1 - skip_generations, 0, -1):
if self.is_group_model and individual_subjs and (i == len(generations) - 1):
self._approximate_map_subj(fall_to_simplex=fall_to_simplex, minimizer=minimizer, use_basin=use_basin, debug=debug, minimizer_kwargs=minimizer_kwargs, basin_kwargs=basin_kwargs)
continue
View
4 setup.py
@@ -8,6 +8,6 @@
url="http://github.com/hddm-devs/kabuki",
packages=["kabuki"],
description="kabuki is a python toolbox that allows easy creation of hierarchical bayesian models for the cognitive sciences.",
- install_requires=['NumPy >= 1.6.0', 'PyMC == 2.3', 'pandas >= 0.10.0', 'matplotlib >= 1.0.0'],
- setup_requires=['NumPy >= 1.6.0', 'PyMC == 2.3', 'pandas >= 0.10.0', 'matplotlib >= 1.0.0']
+ install_requires=['NumPy >= 1.6.0', 'pymc == 2.3.2', 'pandas >= 0.10.0', 'matplotlib >= 1.0.0'],
+ setup_requires=['NumPy >= 1.6.0', 'pymc == 2.3.2', 'pandas >= 0.10.0', 'matplotlib >= 1.0.0']
)
Please sign in to comment.
Something went wrong with that request. Please try again.