New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

It looks like a CVE-2016-0752's PoC #1

Open
jx6f opened this Issue Jun 3, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@jx6f

jx6f commented Jun 3, 2016

There are 2 reasons why I think so.

  • This PoC is same as the nVisium blog's one.

Here is the article.
https://nvisium.com/blog/2016/01/26/rails-dynamic-render-to-rce-cve-2016-0752/

Step 3's command can replace to below.
curl 'http://localhost:3000/exploits?id\[inline\]=<%25%3Did%25>'

  • Rails version of dh-CVE_2016_2098

In Gemfile, It's Rails 4.2.4.
When I update to 4.2.5.1, the PoC is no longer work.
4.2.5.1 is the version, CVE-2016-0752 has fixed, but CVE-2016-2098 has not.

Is this a correct PoC of CVE-2016-2098?
Please tell me!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment