Permalink
Browse files

drops support to 1.9.2, adds support to 2.0.0 in .travis.yml and requ…

…ire a version of ruby at least 1.9.3
  • Loading branch information...
1 parent 1b62a0f commit fbbf6e6c80ced9e3fdc627b6cf3e61b1e60d6cbf @helios committed Jul 24, 2013
Showing with 5 additions and 3 deletions.
  1. +3 −1 .travis.yml
  2. +1 −1 Rakefile
  3. +1 −1 bio-gem.gemspec
View
@@ -1,7 +1,9 @@
language: ruby
rvm:
- - 1.9.2
+
+ - 2.0.0
- 1.9.3
+# - 1.9.2
- jruby-19mode # JRuby in 1.9 mode
# - rbx-19mode # rvm install rbx -- --enable-version=1.9,1.8 --default-version=1.9
# - 1.8.7
View
@@ -24,7 +24,7 @@ Jeweler::Tasks.new do |gem|
# and development dependencies are only needed for development (ie running rake tasks, tests, etc)
#gem.version='0.0.1'
gem.rdoc_options << '--main' << 'README' << '--line-numbers'
- gem.required_ruby_version = ">= 1.9"
+ gem.required_ruby_version = ">= 1.9.3"
gem.extra_rdoc_files = ['LICENSE.txt', 'README.rdoc','Tutorial.rdoc']
end
View
@@ -70,7 +70,7 @@ Gem::Specification.new do |s|
s.licenses = ["MIT"]
s.rdoc_options = ["--main", "README", "--line-numbers"]
s.require_paths = ["lib"]
- s.required_ruby_version = Gem::Requirement.new(">= 1.9")
+ s.required_ruby_version = Gem::Requirement.new(">= 1.9.3")
s.rubygems_version = "2.0.0"
s.summary = "Biogem is a software generator for Ruby in bioinformatics"

0 comments on commit fbbf6e6

Please sign in to comment.