Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support bash before v4.4 #52

Merged
merged 1 commit into from Apr 13, 2022
Merged

Support bash before v4.4 #52

merged 1 commit into from Apr 13, 2022

Conversation

gjkim42
Copy link
Contributor

@gjkim42 gjkim42 commented Jan 27, 2022

Currently, kind-action does not work in an environment of having bash before 4.4(e.g. CentOS 7.9) with the following error.

... args[@]: unbound variable

This PR makes kind-action support bash before v4.4.

ref: https://stackoverflow.com/questions/7577052/bash-empty-array-expansion-with-set-u

Signed-off-by: Gunju Kim <gjkim042@gmail.com>
@gjkim42
Copy link
Contributor Author

@gjkim42 gjkim42 commented Jan 28, 2022

/cc @davidkarlsen
Could you PTAL? Thanks!

@cpanato cpanato closed this Apr 13, 2022
@cpanato cpanato reopened this Apr 13, 2022
Copy link
Member

@cpanato cpanato left a comment

thanks!

@cpanato cpanato merged commit bb50f49 into helm:main Apr 13, 2022
4 checks passed
@gjkim42 gjkim42 deleted the fix-before-bash4.4 branch Apr 13, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants