Skip to content
Newer
Older
100644 37 lines (32 sloc) 1.39 KB
62900b1 @moomerman initial commit
moomerman authored Nov 4, 2010
1 # -*- encoding: utf-8 -*-
2
3 Gem::Specification.new do |s|
4 s.name = %q{asset_id}
1a4287c @moomerman bugfix release
moomerman authored May 15, 2011
5 s.version = "0.2.4"
62900b1 @moomerman initial commit
moomerman authored Nov 4, 2010
6
7 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
8 s.authors = ["Richard Taylor"]
2f80371 @moomerman much more modular codebase, will allow for other backends. Added css …
moomerman authored May 15, 2011
9 s.date = %q{2011-05-15}
62900b1 @moomerman initial commit
moomerman authored Nov 4, 2010
10 s.description = %q{asset_id is a library for uploading static assets to Amazon S3.}
11 s.email = %q{moomerman@gmail.com}
0711c1d @moomerman fixed problem with the last build
moomerman authored May 15, 2011
12 s.files = ["LICENSE", "README.textile","lib/asset_id.rb"] + Dir.glob('lib/asset_id/*.rb') + Dir.glob('lib/asset_id/backend/*.rb')
62900b1 @moomerman initial commit
moomerman authored Nov 4, 2010
13 s.has_rdoc = false
14 s.homepage = %q{http://github.com/moomerman/asset_id}
15 s.rdoc_options = ["--inline-source", "--charset=UTF-8"]
16 s.require_paths = ["lib"]
17 s.rubyforge_project = %q{asset_id}
18 s.rubygems_version = %q{1.3.1}
19 s.summary = %q{asset_id is a library for uploading static assets to Amazon S3.}
20
21 if s.respond_to? :specification_version then
22 current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
23 s.specification_version = 2
24
25 if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
26 s.add_runtime_dependency(%q<mime-types>, [">= 1.16"])
f8d414d @hemang aws-sdk
authored May 12, 2012
27 s.add_runtime_dependency(%q<aws-sdk>, ["~>1.4.1"])
62900b1 @moomerman initial commit
moomerman authored Nov 4, 2010
28 else
29 s.add_dependency(%q<mime-types>, [">= 1.16"])
f8d414d @hemang aws-sdk
authored May 12, 2012
30 s.add_dependency(%q<aws-sdk>, ["~>1.4.1"])
62900b1 @moomerman initial commit
moomerman authored Nov 4, 2010
31 end
32 else
33 s.add_dependency(%q<mime-types>, [">= 1.16"])
f8d414d @hemang aws-sdk
authored May 12, 2012
34 s.add_dependency(%q<aws-sdk>, ["~>1.4.1"])
62900b1 @moomerman initial commit
moomerman authored Nov 4, 2010
35 end
36 end
Something went wrong with that request. Please try again.