Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fix the Visual Studio solution not building after a fresh clone. #26

Merged
merged 1 commit into from

3 participants

@WilbertOnGithub

When someone clones the repository and wants to compile the
master branch (up to the latest commit fed9535),
the solution will not compile because of a missing SharedAssemblyInfo.cs

This file was deleted in commit e5dfc76.

I simply retrieved the file from a commit just before that and added it
again.

Now everyone can clone the repository and compile the solution without
running into compilation errors.

@WilbertOnGithub WilbertOnGithub Fix the solution not building after a fresh clone.
When someone clones the repository and wants to compile the
master branch (up to the latest commit fed9535519a1a918ed6734001b7f5c3a83dd8a10),
the solution will not compile because of a missing SharedAssemblyInfo.cs

This file was deleted in commit e5dfc7643a22e997cb993132eef65c4a19d1bc35.

I simply retrieved the file from a commit just before that and added it
again.

Now everyone can clone the repository and compile the solution without
running into compilation errors...
fcc9a6c
@irontoby

Would like to see this merged; master branch still doesn't build on a fresh checkout (also, SharedAssemblyInfo.cs is still in .gitignore)

Owner

Well, I guess it won't hurt to merge that pull request. I don't remember the reason for not pulling it if there ever was any.
Sorry for the, ahem ..., 2 years delay ;)

Thanks for filing pull requests!

Thanks guys, I was confused by the GitHub interface & didn't realize at first this was from a forked repo (thus my comment was edited from the original). I guess the fork no longer exists which is why I couldn't find the branch or the commit from the command line.

@henon henon merged commit 5662727 into henon:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 23, 2011
  1. @WilbertOnGithub

    Fix the solution not building after a fresh clone.

    WilbertOnGithub authored
    When someone clones the repository and wants to compile the
    master branch (up to the latest commit fed9535519a1a918ed6734001b7f5c3a83dd8a10),
    the solution will not compile because of a missing SharedAssemblyInfo.cs
    
    This file was deleted in commit e5dfc7643a22e997cb993132eef65c4a19d1bc35.
    
    I simply retrieved the file from a commit just before that and added it
    again.
    
    Now everyone can clone the repository and compile the solution without
    running into compilation errors...
This page is out of date. Refresh to see the latest.
Showing with 13 additions and 0 deletions.
  1. +13 −0 SharedAssemblyInfo.cs
View
13 SharedAssemblyInfo.cs
@@ -0,0 +1,13 @@
+using System.Reflection;
+using System.Runtime.CompilerServices;
+using System.Runtime.InteropServices;
+
+[assembly: AssemblyCompany("The Git Development Community")]
+[assembly: AssemblyCopyright("Copyright © 2009 The GitSharp Team")]
+[assembly: ComVisible(false)]
+
+#if DEBUG
+[assembly: AssemblyConfiguration("Debug")]
+#else
+[assembly: AssemblyConfiguration("Release")]
+#endif
Something went wrong with that request. Please try again.