Skip to content
Permalink
Browse files

Align on using / supporting the current stable Yarn version 1.17.3

Signed-off-by: Martin Nonnenmacher <martin.nonnenmacher@here.com>
  • Loading branch information...
mnonnenmacher committed Jul 22, 2019
1 parent ed54574 commit b8f67fd67066f5b3e7291478aff8c3b7b55a0034
Showing with 6 additions and 6 deletions.
  1. +1 −1 .appveyor.yml
  2. +1 −1 .travis.yml
  3. +1 −1 README.md
  4. +1 −1 analyzer/src/main/kotlin/managers/Yarn.kt
  5. +1 −1 docker/run/Dockerfile
  6. +1 −1 docs/GettingStarted.md
@@ -13,7 +13,7 @@ environment:
SBT_VERSION: 1.0.2
STACK_VERSION: 2.1.1
VIRTUAL_ENV_VERSION: 15.1.0
YARN_VERSION: 1.16.0
YARN_VERSION: 1.17.3

cache:
- $(HOME)\.gradle\caches\build-cache-1
@@ -33,7 +33,7 @@ env:
- PHP_VERSION="7.1"
- RUST_VERSION="1.35.0"
- STACK_VERSION="2.1.1"
- YARN_VERSION="1.16.0"
- YARN_VERSION="1.17.3"

before_install:
- sudo rm -f $JAVA_HOME/lib/security/cacerts
@@ -80,7 +80,7 @@ Install these additional prerequisites:
`JAVA_HOME` environment variable accordingly.
* For the Web App reporter:
* [Node.js](https://nodejs.org) 8.*
* [Yarn](https://yarnpkg.com) 1.9.* - 1.16.*
* [Yarn](https://yarnpkg.com) 1.9.* - 1.17.*

Change into the created directory and run `./gradlew installDist` (on the first run this will bootstrap Gradle and
download all required dependencies).
@@ -54,7 +54,7 @@ class Yarn(

override fun command(workingDir: File?) = if (Os.isWindows) "yarn.cmd" else "yarn"

override fun getVersionRequirement(): Requirement = Requirement.buildNPM("1.3.* - 1.16.*")
override fun getVersionRequirement(): Requirement = Requirement.buildNPM("1.3.* - 1.17.*")

override fun mapDefinitionFiles(definitionFiles: List<File>) =
PackageJsonUtils.mapDefinitionFilesForYarn(definitionFiles).toList()
@@ -41,7 +41,7 @@ ENV \
PYTHON_PIP_VERSION=18.1-5 \
PYTHON_VIRTUALENV_VERSION=15.1.0 \
SBT_VERSION=0.13.13-2 \
YARN_VERSION=1.16.0 \
YARN_VERSION=1.17.3 \
# Scanner versions.
SCANCODE_VERSION=2.9.7

@@ -19,7 +19,7 @@ tools need to be installed. In the context of this tutorial the following tools
* Git (any recent version will do)
* [Node.js](https://nodejs.org) 8.*
* [NPM](https://www.npmjs.com) 5.5.* - 6.4.*
* [Yarn](https://yarnpkg.com) 1.9.* - 1.16.*
* [Yarn](https://yarnpkg.com) 1.9.* - 1.17.*

For the full list of supported package managers and Version Control Systems see the [README](../README.md).

0 comments on commit b8f67fd

Please sign in to comment.
You can’t perform that action at this time.