move pg:upgrade and pg:maintenance from pg-extras #1141

Merged
merged 1 commit into from Jul 17, 2014

6 participants

@will will referenced this pull request in heroku/heroku-pg-extras Jul 16, 2014
Closed

Move :upgrade and :maintenance to the main CLI #91

@will

@mattsoldo @heroku/department-of-data both these two commands?

@gregburek

LGTM!

@mattsoldo
@pedro

Looks good, merging.
I'm out though so check with Phil if you need this released before July 28.

@pedro pedro merged commit adb9af7 into heroku:master Jul 17, 2014

1 check passed

Details continuous-integration/travis-ci The Travis CI build passed
@will

@technomancy hey could you do a CLI release for us friendly @heroku/department-of-data folks?

@technomancy

Yeah, I can cut a new version. Is this a minor version bump?

@will

It's two new commands, so +minor seems semvery

@will

thanks in advance

@technomancy

I've pushed out 3.9.2 and tested it on Debian, but I don't have a Mac readily accessible; can you confirm the auto-update works there?

@will

thanks afterwards

I don't have the toolbelt but gem install worked

Last login: Mon Jul 21 15:36:26 on ttys001
~ ➤ heroku pg:upgrade
 !    `pg:upgrade` is not a heroku command.
 !    Perhaps you meant `apps:upgrade` or `upgrade`.
 !    See `heroku help` for a list of available commands.
~ ➤ gem install heroku
zsh: correct 'heroku' to '.heroku' [nyae]? n
WARN: Unresolved specs during Gem::Specification.reset:
      rake (>= 0.8.1)
WARN: Clearing out unresolved specs.
Please report a bug if this causes problems.
Fetching: excon-0.38.0.gem (100%)
Successfully installed excon-0.38.0
Fetching: heroku-api-0.3.19.gem (100%)
Successfully installed heroku-api-0.3.19
Fetching: heroku-3.9.2.gem (100%)
 !    The `heroku` gem has been deprecated and replaced with the Heroku Toolbelt.
 !    Download and install from: https://toolbelt.heroku.com
 !    For API access, see: https://github.com/heroku/heroku.rb
Successfully installed heroku-3.9.2
3 gems installed
~ ➤ heroku pg:upgrade
 !    Usage: heroku pg:upgrade REPLICA
 !    Must specify REPLICA to upgrade.
~ ➤

I'll try to find someone with os x and the toolbelt

@will

On @hgmnz it says 'nothing to update' and he's on 3.9.1

@hgmnz
Heroku member
$ heroku update
Updating from 3.9.1... done, nothing to update
@technomancy

Had to roll this back since it caused https://status.heroku.com/incidents/650

@technomancy

That is, the 3.9.2 release caused this, not the new postgres commands specifically.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment