Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Error while installing a gem on a windows XP platform. #11

Closed
jamespedid opened this Issue · 2 comments

4 participants

@jamespedid

I'm receiving an error during the gem installation process. The verbose output looks like the following:

GET http://rubygems.org/specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/specs.4.8.gz
304 Not Modified
GET http://rubygems.org/latest_specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
304 Not Modified
Installing gem vulcan-0.3.0
Using local gem C:/Ruby193/lib/ruby/gems/1.9.1/cache/vulcan-0.3.0.gem
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/bin/vulcan
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/lib/vulcan/cli.rb
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/lib/vulcan/version.rb
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/lib/vulcan.rb
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/README.md
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/bin/make
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/lib/on.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/lib/spawner.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/History.md
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/index.html
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/index.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/lib/connect-form.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/LICENSE
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/Makefile
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/benchmark/bench-multipart-parser.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/example/post.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/example/upload.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/index.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/lib/file.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/lib/incoming_form.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/lib/index.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/lib/multipart_parser.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/lib/querystring_parser.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/lib/util.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/Makefile
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/package.json
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/Readme.md
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/test/common.js
C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/test/fast/test-incoming-form.js
ERROR: While executing gem ... (Errno::EINVAL)
Invalid argument - C:/Ruby193/lib/ruby/gems/1.9.1/gems/vulcan-0.3.0/server/node_modules/connect-form/node_modules/formidable/test/fixture/file/:

@luislavena

@jamespedid is this still valid? latest version is 0.6.0 and seems that the fixture file from formidable is gone (which was the culprit)

Can you test again and let us know?

Thank you.

@gulopine
Owner

I was running into this same error on Windows Vista prior to 0.6.0, and now that I've tried again, 0.6.0 installs just fine. I'm having other issues with it, but I expect those are unique to my machine (and if not, they'd be another issue anyway).

Thanks!

@wuputah wuputah closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.