New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ERROR #1733

Closed
ifgyong opened this Issue Jan 30, 2016 · 2 comments

Comments

2 participants
@ifgyong

ifgyong commented Jan 30, 2016

MacBook:ifgyong.github.io fgy$ hexo -v
[Error: Module version mismatch. Expected 46, got 47.]
{ [Error: Cannot find module './build/default/DTraceProviderBindings'] code: 'MODULE_NOT_FOUND' }
{ [Error: Cannot find module './build/Debug/DTraceProviderBindings'] code: 'MODULE_NOT_FOUND' }
hexo: 3.1.1
os: Darwin 15.3.0 darwin x64
http_parser: 2.5.0
node: 4.2.4
v8: 4.5.103.35
uv: 1.7.5
zlib: 1.2.8
ares: 1.10.1-DEV
icu: 56.1
modules: 46
openssl: 1.0.2e

I try npm unstall hexo then npm install hexo --no-optional --save,but it don`t work for me.

@ifgyong

This comment has been minimized.

Show comment
Hide comment
@ifgyong

ifgyong Jan 30, 2016

update npm like sudo npm i -g npm,then npm install hexo --no-optional --save,it works for me.

ifgyong commented Jan 30, 2016

update npm like sudo npm i -g npm,then npm install hexo --no-optional --save,it works for me.

@leggetter

This comment has been minimized.

Show comment
Hide comment
@leggetter

leggetter commented Aug 9, 2016

Related #1742 (comment)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment