New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

After I run 'hexo g', my articles are empty #3264

Open
LibraTang opened this Issue Sep 19, 2018 · 4 comments

Comments

2 participants
@LibraTang

LibraTang commented Sep 19, 2018

Environment Info

Node version(node -v): v8.11.4

Your site _config.yml (Optional):

Your theme _config.yml (Optional): archer

Hexo and Plugin version(npm ls --depth 0):

For BUG

My articles are empty when I runhexo g. It happened on my site libratang.github.io .

For question

When I open my article on my blog, it shows nothing.

@tcrowe

This comment has been minimized.

Show comment
Hide comment
@tcrowe

tcrowe Sep 24, 2018

Contributor

Hey @LibraTang 👋

What's the result of this command? npm ls --depth 0

It might be an issue with missing renderer plugin.

Contributor

tcrowe commented Sep 24, 2018

Hey @LibraTang 👋

What's the result of this command? npm ls --depth 0

It might be an issue with missing renderer plugin.

@tcrowe tcrowe added the question label Sep 24, 2018

@LibraTang

This comment has been minimized.

Show comment
Hide comment
@LibraTang

LibraTang Sep 25, 2018

The result of the commandnpm ls --depth 0:

C:\Users\汤
`-- hexo-deployer-git@0.3.1

npm ERR! extraneous: is-number@4.0.0 C:\Users\汤\node_modules\randomatic\node_modules\is-number
npm ERR! extraneous: kind-of@6.0.2 C:\Users\汤\node_modules\randomatic\node_modules\kind-of
npm ERR! extraneous: node-pre-gyp@0.10.0 C:\Users\汤\node_modules\fsevents\node_modules\node-pre-gyp
npm ERR! extraneous: wordwrap@0.0.2 C:\Users\汤\node_modules\yargs\node_modules\wordwrap

LibraTang commented Sep 25, 2018

The result of the commandnpm ls --depth 0:

C:\Users\汤
`-- hexo-deployer-git@0.3.1

npm ERR! extraneous: is-number@4.0.0 C:\Users\汤\node_modules\randomatic\node_modules\is-number
npm ERR! extraneous: kind-of@6.0.2 C:\Users\汤\node_modules\randomatic\node_modules\kind-of
npm ERR! extraneous: node-pre-gyp@0.10.0 C:\Users\汤\node_modules\fsevents\node_modules\node-pre-gyp
npm ERR! extraneous: wordwrap@0.0.2 C:\Users\汤\node_modules\yargs\node_modules\wordwrap
@tcrowe

This comment has been minimized.

Show comment
Hide comment
@tcrowe

tcrowe Sep 25, 2018

Contributor

Uh oh 😦 It's missing most of the modules.

It might help if you generate a new project and compare the files. The default package json has many hexo plugins in it. npm install -g hexo-cli@latest && mkdir my-site && cd my-site && hexo init

Contributor

tcrowe commented Sep 25, 2018

Uh oh 😦 It's missing most of the modules.

It might help if you generate a new project and compare the files. The default package json has many hexo plugins in it. npm install -g hexo-cli@latest && mkdir my-site && cd my-site && hexo init

@LibraTang

This comment has been minimized.

Show comment
Hide comment
@LibraTang

LibraTang Sep 26, 2018

Uh oh 😦 It's missing most of the modules.

It might help if you generate a new project and compare the files. The default package json has many hexo plugins in it. npm install -g hexo-cli@latest && mkdir my-site && cd my-site && hexo init

I'll try it. Thank you!

LibraTang commented Sep 26, 2018

Uh oh 😦 It's missing most of the modules.

It might help if you generate a new project and compare the files. The default package json has many hexo plugins in it. npm install -g hexo-cli@latest && mkdir my-site && cd my-site && hexo init

I'll try it. Thank you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment