New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

用npm更新过hexo的版本的话,可能导致一点小问题 #650

Closed
qazwsxedc121 opened this Issue May 31, 2014 · 4 comments

Comments

5 participants
@qazwsxedc121

qazwsxedc121 commented May 31, 2014

最近用npm update hexo -g了一下,由于原来用的是老版本,所以package.json没有变,也就是说dependencies里面没有hexo-render系列,这样的话如果用

hexo generate

只会把index的template写到index.html里面,并不会生成网站(折腾了好久发现是这个问题)

是不是需要增加个错误提示?没有错误提示的话好像完全不知道问题出在哪里了(老版本用户不知道本地的blog文件夹下的node-modules里面还要装东西)

@heruoxin

This comment has been minimized.

Show comment
Hide comment
@heruoxin

heruoxin Jun 1, 2014

谢谢楼上,我也折腾了好久,原来是这个问题……

heruoxin commented Jun 1, 2014

谢谢楼上,我也折腾了好久,原来是这个问题……

@luabish

This comment has been minimized.

Show comment
Hide comment
@luabish

luabish Jun 6, 2014

这个怎么解决呢 ?

luabish commented Jun 6, 2014

这个怎么解决呢 ?

@heruoxin

This comment has been minimized.

Show comment
Hide comment
@heruoxin

heruoxin Jun 6, 2014

@5ber 手动编辑 package.json ,在 dependencies 里添加
"hexo-renderer-ejs": "",
"hexo-renderer-stylus": "
",
"hexo-renderer-marked": "*"
之后在当前目录 npm install 一次即可。

heruoxin commented Jun 6, 2014

@5ber 手动编辑 package.json ,在 dependencies 里添加
"hexo-renderer-ejs": "",
"hexo-renderer-stylus": "
",
"hexo-renderer-marked": "*"
之后在当前目录 npm install 一次即可。

@imZack

This comment has been minimized.

Show comment
Hide comment
@imZack

imZack Jun 6, 2014

👍 tks.

imZack commented Jun 6, 2014

👍 tks.

@tommy351 tommy351 added the question label Jun 21, 2014

@tommy351 tommy351 closed this Jun 21, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment