Permalink
Browse files

Updated VirtualBox gem dependency to 0.5.4

  • Loading branch information...
mitchellh committed Mar 18, 2010
1 parent bd3a241 commit d548b451d9aa1896051949f2a4355e8b4bbac599
Showing with 14 additions and 7 deletions.
  1. +1 −1 Gemfile
  2. +1 −1 Rakefile
  3. +12 −5 vagrant.gemspec
View
@@ -1,7 +1,7 @@
source :gemcutter
# Gems required for the lib to even run
-gem "virtualbox", ">= 0.5.3"
+gem "virtualbox", ">= 0.5.4"
gem "net-ssh", ">= 2.0.19"
gem "net-scp", ">= 1.0.2"
gem "git-style-binaries", ">= 0.1.10"
View
@@ -10,7 +10,7 @@ begin
gemspec.homepage = "http://github.com/mitchellh/vagrant"
gemspec.authors = ["Mitchell Hashimoto", "John Bender"]
- gemspec.add_dependency('virtualbox', '>= 0.5.3')
+ gemspec.add_dependency('virtualbox', '>= 0.5.4')
gemspec.add_dependency('net-ssh', '>= 2.0.19')
gemspec.add_dependency('net-scp', '>= 1.0.2')
gemspec.add_dependency('json', '>= 1.2.0')
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Mitchell Hashimoto", "John Bender"]
- s.date = %q{2010-03-16}
+ s.date = %q{2010-03-17}
s.description = %q{Vagrant is a tool for building and distributing virtualized development environments.}
s.email = ["mitchell.hashimoto@gmail.com", "john.m.bender@gmail.com"]
s.executables = ["vagrant", "vagrant-box", "vagrant-down", "vagrant-halt", "vagrant-init", "vagrant-package", "vagrant-reload", "vagrant-resume", "vagrant-ssh", "vagrant-status", "vagrant-suspend", "vagrant-up"]
@@ -82,8 +82,11 @@ Gem::Specification.new do |s|
"lib/vagrant/ssh.rb",
"lib/vagrant/stacked_proc_runner.rb",
"lib/vagrant/util.rb",
+ "lib/vagrant/util/errors.rb",
+ "lib/vagrant/util/template_renderer.rb",
"lib/vagrant/vm.rb",
- "templates/Vagrantfile",
+ "templates/Vagrantfile.erb",
+ "templates/errors.yml",
"test/test_helper.rb",
"test/vagrant/actions/base_test.rb",
"test/vagrant/actions/box/add_test.rb",
@@ -124,6 +127,8 @@ Gem::Specification.new do |s|
"test/vagrant/provisioners/chef_test.rb",
"test/vagrant/ssh_test.rb",
"test/vagrant/stacked_proc_runner_test.rb",
+ "test/vagrant/util/errors_test.rb",
+ "test/vagrant/util/template_renderer_test.rb",
"test/vagrant/util_test.rb",
"test/vagrant/vm_test.rb",
"vagrant.gemspec"
@@ -174,6 +179,8 @@ Gem::Specification.new do |s|
"test/vagrant/provisioners/chef_test.rb",
"test/vagrant/ssh_test.rb",
"test/vagrant/stacked_proc_runner_test.rb",
+ "test/vagrant/util/errors_test.rb",
+ "test/vagrant/util/template_renderer_test.rb",
"test/vagrant/util_test.rb",
"test/vagrant/vm_test.rb"
]
@@ -183,22 +190,22 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<virtualbox>, [">= 0.5.3"])
+ s.add_runtime_dependency(%q<virtualbox>, [">= 0.5.4"])
s.add_runtime_dependency(%q<net-ssh>, [">= 2.0.19"])
s.add_runtime_dependency(%q<net-scp>, [">= 1.0.2"])
s.add_runtime_dependency(%q<json>, [">= 1.2.0"])
s.add_runtime_dependency(%q<git-style-binaries>, [">= 0.1.10"])
s.add_runtime_dependency(%q<archive-tar-minitar>, ["= 0.5.2"])
else
- s.add_dependency(%q<virtualbox>, [">= 0.5.3"])
+ s.add_dependency(%q<virtualbox>, [">= 0.5.4"])
s.add_dependency(%q<net-ssh>, [">= 2.0.19"])
s.add_dependency(%q<net-scp>, [">= 1.0.2"])
s.add_dependency(%q<json>, [">= 1.2.0"])
s.add_dependency(%q<git-style-binaries>, [">= 0.1.10"])
s.add_dependency(%q<archive-tar-minitar>, ["= 0.5.2"])
end
else
- s.add_dependency(%q<virtualbox>, [">= 0.5.3"])
+ s.add_dependency(%q<virtualbox>, [">= 0.5.4"])
s.add_dependency(%q<net-ssh>, [">= 2.0.19"])
s.add_dependency(%q<net-scp>, [">= 1.0.2"])
s.add_dependency(%q<json>, [">= 1.2.0"])

0 comments on commit d548b45

Please sign in to comment.