Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

file 50 lines (42 sloc) 1.865 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
# -*- encoding: utf-8 -*-
require File.expand_path("../lib/veewee/version", __FILE__)

Gem::Specification.new do |s|
  s.name = "veewee"
  s.version = Veewee::VERSION
  s.platform = Gem::Platform::RUBY
  s.authors = ["Patrick Debois" ]
  s.email = ["patrick.debois@jedi.be"]
  s.homepage = "http://github.com/jedi4ever/veewee/"
  s.summary = %q{Vagrant box creation}
  s.description = %q{Expand the 'vagrant box' command to support the creation of base boxes from scratch}

  s.required_rubygems_version = ">= 1.3.6"
  s.rubyforge_project = "veewee"

  s.add_dependency "vagrant", ">= 0.9"

  # Currently locked to 2.2.0
  # if specifying to >= 2.2.0 it would use 2.3 and bundler would go in a resolver loop
  # DEBUG_RESOLVER=1 bundle install
  s.add_dependency "net-ssh", "~> 2.2.0"

  s.add_dependency "popen4", "~> 0.1.2"
  s.add_dependency "thor", "~> 0.15"
  s.add_dependency "highline"
  s.add_dependency "progressbar"
  s.add_dependency "i18n"
  s.add_dependency "cucumber", ">=1.0.0"
  s.add_dependency "ansi", "~> 1.3.0"
  s.add_dependency "ruby-vnc", "~> 1.0.0"
  s.add_dependency "fog", "~> 1.4"
  s.add_dependency "childprocess"
  s.add_dependency "grit"
  s.add_dependency "fission", "0.4.0"

  # Modified dependency version, as libxml-ruby dependency has been removed in version 2.1.1
  # See : https://github.com/ckruse/CFPropertyList/issues/14
  # See : https://github.com/jedi4ever/veewee/issues/6
  #s.add_dependency "CFPropertyList", ">= 2.1.1"
# s.add_dependency "libvirt"
  s.add_dependency "rspec", "~> 2.5"

  s.add_development_dependency "bundler", ">= 1.0.0"
  #s.add_development_dependency('ruby-libvirt','~>0.4.0')

  s.files = `git ls-files`.split("\n")
  s.executables = `git ls-files`.split("\n").map{ |f| f =~ /^bin\/(.*)/ ? $1 : nil }.compact
  s.require_path = 'lib'
end
Something went wrong with that request. Please try again.