Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
A mirror of MediaWiki's Subversion repository produced with git-svn(1)
branch: LQTRewrite@715…

This branch is even with brion:LQTRewrite@71586

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
api
classes
compat
i18n
icons
images
import
jquery
js
pages
schema-changes
LICENSE
LiquidThreads.php
LqtFunctions.php
README
lqt.css
lqt.js
lqt.pg.sql
lqt.sql
migrateDatabase.php
newmessages.js

README

STATUS:
======

This software is beta. There are bugs and missing features. But it is
basically usable, and you are encouraged to try it (with caution). Also, please
hack Liquid Threads and make it more awesome.

INSTALLATION:
============

1. Rename this directory to extensions/LiquidThreads inside your
   MediaWiki directory.
2. Add database tables from lqt.sql using the sql.php MediaWiki tool.
   (On Unix, if the current directory is the MediaWiki root directory, you can
   say "php maintenance/sql.php extensions/LiquidThreads/lqt.sql".)
   If you haven't created the AdminSettings.php file, you will have to do that
   first; see http://www.mediawiki.org/wiki/Manual:AdminSettings.php
   Alternatively, you can run lqt.sql manually (you can use the command
   "mysql -u $USER -p -e 'source lqt.sql'" on Unix), but you might have to
   edit it first, and replace the /*$wgDBprefix*/ and /*$wgDBTableOptions*/
   strings with the corresponding settings.
3. Add this line to the end of your LocalSettings.php:
   require_once( "$IP/extensions/LiquidThreads/LiquidThreads.php" );

Liquid Threads uses namespace numbers 90, 91, 92, and 93. If you are using
another extension which uses any of these numbers, you should have Liquid
Threads use different numbers by adding something like the following to your
LocalSettings.php, *before* including LiquidThreads.php:

$egLqtNamespaceNumbers = array(
    'Thread' => 100,
    'Thread_talk' => 101,
    'Summary' => 102,
    'Summary_talk' => 103
);

UPGRADES:
========

If you are upgrading from an earlier version of Liquid Threads, instead of
sourcing lqt.sql, you should source the appropriate schema change files, in
order:

lqt-schema-change-1.sql for before r25931
lqt-schema-change-2.sql for before r26550
lqt-schema-change-3.sql for before r26563
lqt-schema-change-4.sql for before r26575
lqt-schema-change-5.sql for before r28178
lqt-schema-change-6.sql for before r28693

Also, as of 1.14alpha (r39905), the entry point for LiquidThreads is "extensions/
LiquidThreads/LiquidThreads.php" previously, it had ended in "LqtPages.php."
Wikis upgrading with an older configuration need to update this when installing
newer versions, or LiquidThreads will not work.

CONTACT:
=======

* David McCabe
* davemccabe@gmail.com (email or jabber)
* davidmccabe in #mediawiki on irc.freenode.net

CREDITS:
=======

Written by David McCabe, sponsered by COL.org, Wikia.com, and the Google
Summer of Code, with lots of help from Erik Möller, Brion Vibber, and the kind
folks on #mediawiki.

Something went wrong with that request. Please try again.