Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tooltip`s stickOnContact param is not working when useHTML is enabled #13310

Closed
stanvol opened this issue Apr 14, 2020 · 8 comments · Fixed by #13329 or #15960
Closed

Tooltip`s stickOnContact param is not working when useHTML is enabled #13310

stanvol opened this issue Apr 14, 2020 · 8 comments · Fixed by #13329 or #15960

Comments

@stanvol
Copy link

stanvol commented Apr 14, 2020

Expected behaviour

Tooltip should be shown while cursor is over tooltip.

Actual behaviour

Default tooltip`s behavior.

Product version

Highcharts 8.0.4

Affected browser(s)

All

@highsoft-bot highsoft-bot added this to To do in Development-Flow Apr 14, 2020
@pawelfus
Copy link
Contributor

Thanks for reporting this issue @stanvol

Live demo with steps to reproduce the issue

Demo: https://jsfiddle.net/BlackLabel/x8L0etcn/

Steps:

  • mouse move from point (1, 1) to (1, 2)

FYI @bre1470

@bre1470 bre1470 self-assigned this Apr 15, 2020
@bre1470 bre1470 moved this from To do to In progress in Development-Flow Apr 15, 2020
@highsoft-bot highsoft-bot moved this from In progress to Pending Review in Development-Flow Apr 16, 2020
@highsoft-bot highsoft-bot moved this from In progress to Pending Review in Development-Flow Apr 16, 2020
Development-Flow automation moved this from Pending Review to Done Apr 28, 2020
@Izothep Izothep removed this from Done in Development-Flow Jul 15, 2021
@Tom-E
Copy link

Tom-E commented Jul 21, 2021

It looks like this is regressed? I am able to reproduce the bug on the latest highcharts and the original repro demo above.

@raf18seb
Copy link
Contributor

Hi @Tom-E,

I am not able to reproduce the issue in the newest Highcharts. Could you double-check and provide the exact steps to reproduce it?

@Tom-E
Copy link

Tom-E commented Jul 22, 2021

useHtmlBreaksStickOnContact
this is what i'm seeing @raf18seb -- with useHTML, stickonContact doesnt work: we should be able to hover the tooltip instead of switching to the other series.

@raf18seb
Copy link
Contributor

@Tom-E thanks for providing more info.

Indeed, it's a regression after 8d79d26

As a workaround, you can bring back the old code, but it will probably brake #14110
Demo: https://jsfiddle.net/BlackLabel/7hdpfrc5/

Reopening. FYI @khlieng

@khlieng
Copy link
Member

khlieng commented Jul 23, 2021

This is getting fixed in #15960, I have now replaced the useHTML fix with just dealing with the regression, we can probably just close this again as its the same as #14143 (split is unrelated).

@raf18seb
Copy link
Contributor

I'd keep it open until we are sure it's fixed. If you are sure - feel free to close.

@khlieng
Copy link
Member

khlieng commented Jul 23, 2021

So split wasnt actually unrelated, the regression made it look like it was, split broke again after only fixing the regression 🤔, since that makes this issue less of a duplicate I will add it to the PR as well.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment