SVG support incorrectly detected in IE9 set to render as IE7 or 8 #189

Closed
ghost opened this Issue Jan 20, 2011 · 2 comments

Comments

Projects
None yet
1 participant
@ghost

ghost commented Jan 20, 2011

IE9 returns a value for window.SVGAngle even when rendering as IE7 or 8 and then obviously fails when trying to use SVG. This fix method utilizes modernizr.js's detection method and works correctly:

hasSVG = !!doc.createElementNS && !!doc.createElementNS("http://www.w3.org/2000/svg", "svg").createSVGRect

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Jan 21, 2011

Collaborator

When I run www.highcharts.com/demo in IE9, it works in both IE7 and IE8 mode. It is very slow though, but that's because of a VML problem. I'm on the Platform Preview 1.9.8023.6000. What version are you running?

Collaborator

TorsteinHonsi commented Jan 21, 2011

When I run www.highcharts.com/demo in IE9, it works in both IE7 and IE8 mode. It is very slow though, but that's because of a VML problem. I'm on the Platform Preview 1.9.8023.6000. What version are you running?

@ghost

This comment has been minimized.

Show comment
Hide comment

ghost commented Jan 22, 2011

I'm on the latest beta. Other people have experienced it also.

http://stackoverflow.com/questions/4504917/ie-9-in-ie8-browser-mode-document-mode-supports-svg

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment