New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Zero values within heatmap #3295

Closed
gryevns opened this Issue Jul 25, 2014 · 3 comments

Comments

Projects
None yet
2 participants
@gryevns

gryevns commented Jul 25, 2014

When a heatmap contains values of 0 and you resize the window it renders '0' out of place.

http://jsfiddle.net/gryevns/jFc9s/

Also, is there an option to show values of 0 instead of hiding them?

@ghost

This comment has been minimized.

ghost commented Jul 28, 2014

This seems to be a bug in the formatter for the labels. If you add format: '{point.value}', to your datalabel configuration everything works fine. The bug-part is that this is listed as the default value.

@ghost

This comment has been minimized.

ghost commented Jul 28, 2014

It is a bug in the renderer for labels, it does not render 0 as a value correctly. see example
http://jsfiddle.net/stephanevanraes/YYPN2/

ghost pushed a commit that referenced this issue Jul 28, 2014

@ghost ghost closed this Jul 28, 2014

@pawelfus

This comment has been minimized.

Contributor

pawelfus commented Aug 19, 2014

With the demo you provided it works fine, but on a heatmap it's still misplaced:

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment