New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Clippaths wrong size - markers aren't visible #5442

Closed
sebastianbochan opened this Issue Jun 28, 2016 · 4 comments

Comments

Projects
None yet
2 participants
@sebastianbochan
Contributor

sebastianbochan commented Jun 28, 2016

Actual behaviour

Clippaths wrong size - markers aren't visible

Live demo with steps to reproduce

  1. Demo http://jsfiddle.net/nrbfteby/
  2. Click update
  3. Click Resize
  4. Markers aren't visible
@jon-a-nygaard

This comment has been minimized.

Show comment
Hide comment
@jon-a-nygaard

jon-a-nygaard Jun 29, 2016

Collaborator

This seems to have something to do with the customEvents.js, as you can see from the following example it works as exepcted when that script is commented out: http://jsfiddle.net/nrbfteby/2/

Collaborator

jon-a-nygaard commented Jun 29, 2016

This seems to have something to do with the customEvents.js, as you can see from the following example it works as exepcted when that script is commented out: http://jsfiddle.net/nrbfteby/2/

@sebastianbochan

This comment has been minimized.

Show comment
Hide comment
@sebastianbochan

sebastianbochan Jun 29, 2016

Contributor

@jon-a-nygaard I do not agree, let's move the series.update() to callback. Demo: http://jsfiddle.net/rommd1eo/ problem appears, also without customEvents plugin.

Internal note
I noticed that the issue exists, when we call series.update() with the enabled animation and was enabled earlier. See demo with defaulty disabled animation.

http://jsfiddle.net/nhwu3qfz/ it works.

Contributor

sebastianbochan commented Jun 29, 2016

@jon-a-nygaard I do not agree, let's move the series.update() to callback. Demo: http://jsfiddle.net/rommd1eo/ problem appears, also without customEvents plugin.

Internal note
I noticed that the issue exists, when we call series.update() with the enabled animation and was enabled earlier. See demo with defaulty disabled animation.

http://jsfiddle.net/nhwu3qfz/ it works.

@jon-a-nygaard

This comment has been minimized.

Show comment
Hide comment
@jon-a-nygaard

jon-a-nygaard Jun 30, 2016

Collaborator

@sebastianbochan Thanks, will look into what happens in the code. It seems that wether the animation is enabled or not has no impact on the outcome. As long as animation is updated on the series this issue appears.

Edit: except when the animation is set in plotOptions like in your example.

Collaborator

jon-a-nygaard commented Jun 30, 2016

@sebastianbochan Thanks, will look into what happens in the code. It seems that wether the animation is enabled or not has no impact on the outcome. As long as animation is updated on the series this issue appears.

Edit: except when the animation is set in plotOptions like in your example.

@jon-a-nygaard jon-a-nygaard reopened this Jun 30, 2016

@jon-a-nygaard jon-a-nygaard added Bug and removed Not a bug labels Jun 30, 2016

@jon-a-nygaard jon-a-nygaard self-assigned this Jun 30, 2016

@jon-a-nygaard

This comment has been minimized.

Show comment
Hide comment
@jon-a-nygaard

jon-a-nygaard Jun 30, 2016

Collaborator

According to git bisect the first bad commit which broke this functionality is 1351db5

Seen in this example

Collaborator

jon-a-nygaard commented Jun 30, 2016

According to git bisect the first bad commit which broke this functionality is 1351db5

Seen in this example

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment