New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Offline exporting - in IE11 - after zoom series plot is visible outside of plot area #5567

Closed
KacperMadej opened this Issue Aug 5, 2016 · 5 comments

Comments

Projects
None yet
3 participants
@KacperMadej
Contributor

KacperMadej commented Aug 5, 2016

Behaviour

Offline exporting - in IE11 - after zoom series plot is visible outside of plot area in exported image.

Live demo with steps to reproduce

http://jsfiddle.net/cmay2grr/2/
Steps:
0. use IE11

  1. export to any format - image is with the issue visible

Affected browser(s)

IE11, Edge (export to SVG, other formats are not working)

@oysteinmoseng

This comment has been minimized.

Show comment
Hide comment
@oysteinmoseng

oysteinmoseng Aug 15, 2016

Collaborator

The issue also appears in PNG/JPEG export (which should work, by the way??).

The problem seems to be a rouge double quote in the SVG where the clip path is defined for the series.

<g xmlns="http://www.w3.org/2000/svg" class="highcharts-series highcharts-series-0" clip-path="url(#highcharts-6&quot;)"

This double quote is not present when exporting from other browsers.

Collaborator

oysteinmoseng commented Aug 15, 2016

The issue also appears in PNG/JPEG export (which should work, by the way??).

The problem seems to be a rouge double quote in the SVG where the clip path is defined for the series.

<g xmlns="http://www.w3.org/2000/svg" class="highcharts-series highcharts-series-0" clip-path="url(#highcharts-6&quot;)"

This double quote is not present when exporting from other browsers.

@KacperMadej

This comment has been minimized.

Show comment
Hide comment
@KacperMadej

KacperMadej Aug 19, 2016

Contributor

Just to refer to the commit comment - the issue is still visible in IE11.

Contributor

KacperMadej commented Aug 19, 2016

Just to refer to the commit comment - the issue is still visible in IE11.

@oysteinmoseng

This comment has been minimized.

Show comment
Hide comment
@oysteinmoseng

oysteinmoseng Aug 19, 2016

Collaborator

Strange, the SVG used for export now seems to be correct.

Collaborator

oysteinmoseng commented Aug 19, 2016

Strange, the SVG used for export now seems to be correct.

@KacperMadej

This comment has been minimized.

Show comment
Hide comment
@KacperMadej

KacperMadej Sep 27, 2016

Contributor

IE11 - PNG and JPEG are not fixed while SVG is working fine.

In Edge all seems to be working fine now.

Contributor

KacperMadej commented Sep 27, 2016

IE11 - PNG and JPEG are not fixed while SVG is working fine.

In Edge all seems to be working fine now.

@oysteinmoseng

This comment has been minimized.

Show comment
Hide comment
@oysteinmoseng

oysteinmoseng Sep 28, 2016

Collaborator

This is apparently an issue with CanVG, also apparently fixed in the latest version.

Temporary workaround: Include the latest CanVG on your page, and the offline-exporting module will use that instead of the default one.

We will update the CanVG version auto-downloaded for Highcharts 5.0, so this will soon be a non-issue.

Collaborator

oysteinmoseng commented Sep 28, 2016

This is apparently an issue with CanVG, also apparently fixed in the latest version.

Temporary workaround: Include the latest CanVG on your page, and the offline-exporting module will use that instead of the default one.

We will update the CanVG version auto-downloaded for Highcharts 5.0, so this will soon be a non-issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment