New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Setting alternateGridColor in yAxis using themes affects colorAxis. #5569

Closed
Izothep opened this Issue Aug 9, 2016 · 3 comments

Comments

Projects
None yet
3 participants
@Izothep

Izothep commented Aug 9, 2016

Expected behaviour

Setting alternateGridColor in yAxis should not affect colorAxis

Actual behaviour

Right now when using alternateGridColor in yAxis, the colour blocks are visible in the chart. I am posting image showing this issue:

screen shot 2016-08-09 at 12 11 27

Live demo with steps to reproduce

Here you can find the demo showing this issue:
http://jsfiddle.net/tpo8n3bL/4/

As a workaround you can add alternateGridColor in colorAxis (to see the changes uncomment it from the example I gave you).

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus Aug 10, 2016

Contributor

Used to work in 4.1.7 version: http://jsfiddle.net/tpo8n3bL/5/

Fails since: d84d598

Related ticket: #3379

Contributor

pawelfus commented Aug 10, 2016

Used to work in 4.1.7 version: http://jsfiddle.net/tpo8n3bL/5/

Fails since: d84d598

Related ticket: #3379

@pawelfus pawelfus added the Regression label Aug 10, 2016

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Aug 11, 2016

Collaborator

In 4.1.7 and before, the same problem existed, but with the xAxis: http://jsfiddle.net/highcharts/jjy0wkLq/.

It can be discussed whether it is a regression, it is more a bug that has moved.

So the issue is not new, and it is not related to alternativeGridColor. The same thing happens with some other options, like gridLineColor. It has to do with how options are merged into the color axis.

Collaborator

TorsteinHonsi commented Aug 11, 2016

In 4.1.7 and before, the same problem existed, but with the xAxis: http://jsfiddle.net/highcharts/jjy0wkLq/.

It can be discussed whether it is a regression, it is more a bug that has moved.

So the issue is not new, and it is not related to alternativeGridColor. The same thing happens with some other options, like gridLineColor. It has to do with how options are merged into the color axis.

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus Aug 11, 2016

Contributor

Good point! I agree, it's a bug, let change label.

Contributor

pawelfus commented Aug 11, 2016

Good point! I agree, it's a bug, let change label.

@pawelfus pawelfus added Bug and removed Regression labels Aug 11, 2016

@TorsteinHonsi TorsteinHonsi self-assigned this Aug 11, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment