New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Highcharts JS v4.2.6 multiple export giving a blank page both in server side export and client side export. #5570

Closed
vivek00711 opened this Issue Aug 9, 2016 · 4 comments

Comments

Projects
None yet
4 participants
@vivek00711

vivek00711 commented Aug 9, 2016

Expected behaviour

Highcharts JS v4.2.6 -- >Export all chart together.

Actual behaviour

Highcharts JS v4.2.6 -- >Not exporting any chart and giving a blank page.

Live demo with steps to reproduce

http://jsfiddle.net/highcharts/eatqca8n/
http://jsfiddle.net/highcharts/gd7bB/

Affected browser(s)

All major browser.

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Aug 11, 2016

Collaborator

The same happens in our official fiddle as linked from our FAQ: http://jsfiddle.net/highcharts/gd7bB/

To do:

  • Fix the problem
  • Move the demo into our samples/highcharts/exporting section so that it is part of the automated test suite.
  • Update the link from the FAQ.
  • Mention it in the exporting section of the docs (and the API?).
Collaborator

TorsteinHonsi commented Aug 11, 2016

The same happens in our official fiddle as linked from our FAQ: http://jsfiddle.net/highcharts/gd7bB/

To do:

  • Fix the problem
  • Move the demo into our samples/highcharts/exporting section so that it is part of the automated test suite.
  • Update the link from the FAQ.
  • Mention it in the exporting section of the docs (and the API?).
@oysteinmoseng

This comment has been minimized.

Show comment
Hide comment
@oysteinmoseng

oysteinmoseng Aug 17, 2016

Collaborator

Caused by hidden tooltip position now being -9e9 instead of earlier -9999. Can be solved by changing to e.g. -9e7, but we should consider trying to do this with display: none styling instead. Offending code line.

Collaborator

oysteinmoseng commented Aug 17, 2016

Caused by hidden tooltip position now being -9e9 instead of earlier -9999. Can be solved by changing to e.g. -9e7, but we should consider trying to do this with display: none styling instead. Offending code line.

@oysteinmoseng

This comment has been minimized.

Show comment
Hide comment
@oysteinmoseng

oysteinmoseng Aug 17, 2016

Collaborator

We could also strip out the tooltip from the export if it is hidden, to save a few bytes on exported file size.

Collaborator

oysteinmoseng commented Aug 17, 2016

We could also strip out the tooltip from the export if it is hidden, to save a few bytes on exported file size.

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus Aug 17, 2016

Contributor

@oysteinmoseng - there are cases, when tooltip is required by users, for example using tooltip.refresh(point/points). I know that refresh() is not part of the API, but still it is used in our demos and commonly used. Just FYI.

Contributor

pawelfus commented Aug 17, 2016

@oysteinmoseng - there are cases, when tooltip is required by users, for example using tooltip.refresh(point/points). I know that refresh() is not part of the API, but still it is used in our demos and commonly used. Just FYI.

@oysteinmoseng oysteinmoseng added the Docs label Aug 18, 2016

TorsteinHonsi added a commit that referenced this issue Oct 6, 2016

Refactored tooltip delay the generation of the empty label container.…
… This prevents the empty label from being present in exported SVG.

Touches #2301, #2657, #3532, #5570.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment