New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Shared tooltips aren't always activated after hovering over a bubble #5595

Closed
khoomeister opened this Issue Aug 17, 2016 · 4 comments

Comments

Projects
None yet
2 participants
@khoomeister

khoomeister commented Aug 17, 2016

Expected behaviour

Hovering over the blank space of a plot area (i.e. without the mouse cursor touching any other series such as line/area) should always display a tooltip if tooltip.shared = true.

Actual behaviour

However after hovering over a bubble series, as long as the mouse cursor doesn't touch any other series on the same chart, shared tooltips won't activate.

My guess is this probably applies to all other unordered data series as well.

Live demo with steps to reproduce

http://jsfiddle.net/khoomeister/aqpw331y/6/

  1. Mouseover over a bubble and observe tooltip appear.
  2. Mouseout and as long as your cursor doesn't touch the line series, shared tooltips won't appear.
@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Aug 18, 2016

Collaborator

If you set stickyTracking to false on the bubble series, you get the desired result: http://jsfiddle.net/highcharts/aqpw331y/7/

Collaborator

TorsteinHonsi commented Aug 18, 2016

If you set stickyTracking to false on the bubble series, you get the desired result: http://jsfiddle.net/highcharts/aqpw331y/7/

@khoomeister

This comment has been minimized.

Show comment
Hide comment
@khoomeister

khoomeister Aug 19, 2016

Hey @TorsteinHonsi

stickyTracking helped but it was still happening, albeit much less often.

I tracked it down to the use of tooltip.useHTML. If that is set to true, then hovering over the bubble, then the tooltip, and then in the blank plot area without touching any other series will not activate shared tooltips.

Example: http://jsfiddle.net/khoomeister/aqpw331y/9/

khoomeister commented Aug 19, 2016

Hey @TorsteinHonsi

stickyTracking helped but it was still happening, albeit much less often.

I tracked it down to the use of tooltip.useHTML. If that is set to true, then hovering over the bubble, then the tooltip, and then in the blank plot area without touching any other series will not activate shared tooltips.

Example: http://jsfiddle.net/khoomeister/aqpw331y/9/

@khoomeister

This comment has been minimized.

Show comment
Hide comment
@khoomeister

khoomeister Aug 19, 2016

Oh I see I can't reopen, did you want me to create a new issue for it?

khoomeister commented Aug 19, 2016

Oh I see I can't reopen, did you want me to create a new issue for it?

@TorsteinHonsi TorsteinHonsi added Bug and removed Not a bug labels Aug 22, 2016

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Aug 22, 2016

Collaborator

Thanks for elaborating! It happens when we mouse over the tooltip first, then over the plot area. If we mouse out from the bubble to the plot area directly, it hides as expected.

Collaborator

TorsteinHonsi commented Aug 22, 2016

Thanks for elaborating! It happens when we mouse over the tooltip first, then over the plot area. If we mouse out from the bubble to the plot area directly, it hides as expected.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment