New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dataLabels.softConnector does nothing #5868

Closed
wojtekmaj opened this Issue Oct 24, 2016 · 3 comments

Comments

Projects
None yet
3 participants
@wojtekmaj

wojtekmaj commented Oct 24, 2016

Expected behaviour

dataLabels.softConnector changing style of the connector to not softened if set to false.

Actual behaviour

dataLabels.softConnector is not changing style of the connector.

Live demo with steps to reproduce

Click on two examples included in the API under following link. Compare.
http://api.highcharts.com/highcharts/plotOptions.pie.dataLabels.softConnector

Affected browser(s)

All

@wojtekmaj

This comment has been minimized.

Show comment
Hide comment
@wojtekmaj

wojtekmaj Oct 24, 2016

Changing Highcharts version to 4.2.2 in the example makes them working correctly, so the issue is likely to be since 5.0.

wojtekmaj commented Oct 24, 2016

Changing Highcharts version to 4.2.2 in the example makes them working correctly, so the issue is likely to be since 5.0.

@wojtekmaj

This comment has been minimized.

Show comment
Hide comment
@wojtekmaj

wojtekmaj Oct 24, 2016

Looks this.options.softConnector returns undefined and defaults to true in seriesTypes.pie.prototype.connectorPath.

wojtekmaj commented Oct 24, 2016

Looks this.options.softConnector returns undefined and defaults to true in seriesTypes.pie.prototype.connectorPath.

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus Oct 27, 2016

Contributor

@wojtekmaj - thank you for reporting!

Internal note:
No extra unit test, as we already have pie-datalabels-softconnector-false and pie-datalabels-softconnector-true tests.

Contributor

pawelfus commented Oct 27, 2016

@wojtekmaj - thank you for reporting!

Internal note:
No extra unit test, as we already have pie-datalabels-softconnector-false and pie-datalabels-softconnector-true tests.

@pawelfus pawelfus self-assigned this Oct 27, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment