Tooltip formatter doesn't correctly hide the tooltip in Highcharts 5.0.2 #5915

Closed
Rashaine opened this Issue Nov 1, 2016 · 1 comment

Projects

None yet

2 participants

@Rashaine
Rashaine commented Nov 1, 2016

Expected behaviour

Returning false should disable(hide) the tooltip.

Actual behaviour

The tooltip is shown after it is created/initialized (via getLabel()) while the isHidden bool is still set to true so the hide code short-circuits and the empty tooltip remains visible in the upper left corner of the chart.

Live demo with steps to reproduce

http://jsfiddle.net/aepq5rf6/

Hover over the first data point (Jan) and note that the empty tooltip is incorrectly shown. After a valid tooltip is shown the code will function as desired.

Affected browser(s)

Chrome

@TorsteinHonsi
Collaborator

It's a regression, worked in v4: http://jsfiddle.net/highcharts/aepq5rf6/1/

@TorsteinHonsi TorsteinHonsi added a commit that referenced this issue Nov 1, 2016
@TorsteinHonsi TorsteinHonsi Fixed #5915, returning false from tooltip formatter only hid the tool…
…tip when it was present from before.
bab7fc4
@TorsteinHonsi TorsteinHonsi added a commit that closed this issue Nov 3, 2016
@TorsteinHonsi TorsteinHonsi Fixed #5915, returning false from tooltip formatter only hid the tool…
…tip when it was present from before.

# Conflicts:
#	samples/unit-tests/tooltip/formatter/demo.html
#	samples/unit-tests/tooltip/formatter/demo.js
042a8aa
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment