New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pie chart 'Expected arc flag' error #6051

Closed
SuperOleg39 opened this Issue Nov 29, 2016 · 5 comments

Comments

Projects
None yet
4 participants
@SuperOleg39

SuperOleg39 commented Nov 29, 2016

Expected behaviour

Hello!
When I many times clicked on different Pie chart pieces, I catched many errors.
But the chart continues to work steadily.

Actual behaviour

Error message:
Error: <path> attribute d: Expected arc flag ('0' or '1'), "…647399097473 0 0.004450126317012…".

Live demo with steps to reproduce

You can see it on highcharts demo page:
http://www.highcharts.com/demo/pie-basic

Affected browser(s)

Google Chrome 54.0.2840.99 m (64-bit)

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Nov 30, 2016

Collaborator

Thanks for reporting!

I can see errors too, but interestingly, not the same as you. My errors are
VM200 highcharts.js:3674Error: <path> attribute d: Unexpected end of attribute. Expected number, "M".

They can be traced back to d9c7781

Collaborator

TorsteinHonsi commented Nov 30, 2016

Thanks for reporting!

I can see errors too, but interestingly, not the same as you. My errors are
VM200 highcharts.js:3674Error: <path> attribute d: Unexpected end of attribute. Expected number, "M".

They can be traced back to d9c7781

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Nov 30, 2016

Collaborator

Can you verify that the issue is fixed at http://jsfiddle.net/highcharts/hp66m188/?

Collaborator

TorsteinHonsi commented Nov 30, 2016

Can you verify that the issue is fixed at http://jsfiddle.net/highcharts/hp66m188/?

@SuperOleg39

This comment has been minimized.

Show comment
Hide comment
@SuperOleg39

SuperOleg39 Dec 2, 2016

Yes, issue is fixed! :)

Sorry for the long answer!

SuperOleg39 commented Dec 2, 2016

Yes, issue is fixed! :)

Sorry for the long answer!

@karthiknwo

This comment has been minimized.

Show comment
Hide comment
@karthiknwo

karthiknwo Mar 8, 2017

@TorsteinHonsi Can you please mention what caused and what the fix is? I am seeing this when I try to display a dialog when someone clicks on a slice in the pie chart. Any help would be appreciated. Please let me know if you need sample code.

karthiknwo commented Mar 8, 2017

@TorsteinHonsi Can you please mention what caused and what the fix is? I am seeing this when I try to display a dialog when someone clicks on a slice in the pie chart. Any help would be appreciated. Please let me know if you need sample code.

@SuperOleg39

This comment has been minimized.

Show comment
Hide comment
@SuperOleg39

SuperOleg39 Mar 11, 2017

@karthiknwo Just update the library version :)

SuperOleg39 commented Mar 11, 2017

@karthiknwo Just update the library version :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment