New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bubbles are now showing in v5.0.7 if plotOptions.series.marker.enabled set to false #6264

Closed
mengyaow opened this Issue Jan 19, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@mengyaow

mengyaow commented Jan 19, 2017

issue with latest release v5.0.7
Bubble chart is not drawing any bubbles.

my bubble charts are working fine with v5.0.6, but failed with v5.0.7
These 2 JSfiddle have exactly the same js code, only difference is the highchart version being using.
v5.0.6===> everything works fine:
http://jsfiddle.net/519vfcdr/4/
v5.0.7===> bubbles are not drawing:
http://jsfiddle.net/519vfcdr/5/

I try to debug , if I change plotOptions.series.marker.enabled from false to true, then it can draw.
It's an inconsistant behavior in v5.0.7 vs v5.0.6

Affected in Chrome and Firefox

@TorsteinHonsi TorsteinHonsi added the Bug label Jan 19, 2017

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Jan 19, 2017

Collaborator

Thanks for reporting, it is a bug. We refactored bubbles in v5.0.7 in order to use the marker logic from scatter series. This allowed using image symbol markers that was not possible before.

Reduced demo: http://jsfiddle.net/highcharts/519vfcdr/6/ . The second bubble should be visible. With scatter series it works like expected.

Collaborator

TorsteinHonsi commented Jan 19, 2017

Thanks for reporting, it is a bug. We refactored bubbles in v5.0.7 in order to use the marker logic from scatter series. This allowed using image symbol markers that was not possible before.

Reduced demo: http://jsfiddle.net/highcharts/519vfcdr/6/ . The second bubble should be visible. With scatter series it works like expected.

@mengyaow

This comment has been minimized.

Show comment
Hide comment
@mengyaow

mengyaow Jan 20, 2017

I'm using v5.0.6 so the bubble is not a blocking issue,
Thanks for the quick fix !!!!!

mengyaow commented Jan 20, 2017

I'm using v5.0.6 so the bubble is not a blocking issue,
Thanks for the quick fix !!!!!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment