New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Highcharts5.0.9 bar getSVG not work with IE8 #6470

Closed
huoxuxu opened this Issue Mar 15, 2017 · 5 comments

Comments

Projects
None yet
3 participants
@huoxuxu

huoxuxu commented Mar 15, 2017

hello highcharts
when i use highcharts 5.0.9 with IE8,
chartType is bar
then i use getSVG method it‘s not work
error message is 缺少JScript 对象

@zhy1stgg

This comment has been minimized.

Show comment
Hide comment
@zhy1stgg

zhy1stgg Mar 15, 2017

+1
I have the same issue, it's may affect from version 5.0.1

zhy1stgg commented Mar 15, 2017

+1
I have the same issue, it's may affect from version 5.0.1

@KacperMadej

This comment has been minimized.

Show comment
Hide comment
@KacperMadej

KacperMadej Mar 15, 2017

Contributor

Is this function working differently than in previous versions? I have tested the function and getSVG is working fine - it's just hard to display SVG in a browser that doesn't support it. Please provide a demo that should be used to recreate the problem.

Contributor

KacperMadej commented Mar 15, 2017

Is this function working differently than in previous versions? I have tested the function and getSVG is working fine - it's just hard to display SVG in a browser that doesn't support it. Please provide a demo that should be used to recreate the problem.

@huoxuxu

This comment has been minimized.

Show comment
Hide comment
@huoxuxu

huoxuxu commented Mar 17, 2017

123123123

@KacperMadej

This comment has been minimized.

Show comment
Hide comment
@KacperMadej

KacperMadej Mar 20, 2017

Contributor

Thank you for the image. There's a problem with exporting dataLabels. As a workaround you could avoid exporting charts with dataLabels through IE8 or use last working version - 5.0.2. I will be searching for the commit responsible for the problem.

Contributor

KacperMadej commented Mar 20, 2017

Thank you for the image. There's a problem with exporting dataLabels. As a workaround you could avoid exporting charts with dataLabels through IE8 or use last working version - 5.0.2. I will be searching for the commit responsible for the problem.

@KacperMadej

This comment has been minimized.

Show comment
Hide comment
@KacperMadej

KacperMadej Mar 20, 2017

Contributor

Internal note:

Responsible commit: 7ba2913

IE8 throws an error: JScript object expected on this line.

Contributor

KacperMadej commented Mar 20, 2017

Internal note:

Responsible commit: 7ba2913

IE8 throws an error: JScript object expected on this line.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment