New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Charts failing to load in 5.0.10 with JS TypeError: Cannot read property 'getPlotBandPath' of undefined #6641

Closed
goodforenergy opened this Issue Apr 26, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@goodforenergy

goodforenergy commented Apr 26, 2017

Expected behaviour

Charts load without JS error.

Actual behaviour

Charts fail to load with JS error highcharts.js:23873 Uncaught TypeError: Cannot read property 'getPlotBandPath' of undefined

screen shot 2017-04-26 at 3 02 45 pm

screen shot 2017-04-26 at 3 03 16 pm

screen shot 2017-04-26 at 3 07 13 pm

Live demo with steps to reproduce

I'm afraid I've been unable to reproduce in a JSFiddle. Our app uses a lot of Highcharts charts, all of which work fine in 5.0.9. This same error seems to be stopping all of our Highcharts charts from loading.

Here's the configuration for one affected chart, if it's any help:

{
  "chart": {
    "zoomType": "x"
  },
  "legend": {
    "enabled": false
  },
  "xAxis": {
    "minTickInterval": 1,
    "labels": {},
    "title": {},
    "plotBands": []
  },
  "yAxis": {
    "min": 0,
    "title": {
      "text": "Title"
    },
    "plotLines": [{
        "color": "#1a567d", "width": 2, "value": 0, "dashStyle": "ShortDot", "zIndex": 10
      }]
  },
  "plotOptions": {
    "area": {
      "stacking": "normal"
    },
    "areaspline": {
      "stacking": "normal",
      "fillOpacity": 1
    },
    "column": {
      "stacking": "normal"
    }
  },
  "tooltip": {
    "shared": true
  },
  "series": [
    {
      "name": "Series one",
      "type": "spline",
      "data": [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0],
      "color": "#09a1de",
      "events": {}
    },
    {
      "name": "Series two",
      "band": "band",
      "type": "arearange",
      "data": [
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0],
        [0, 0]
      ],
      "color": "#09a1de",
      "events": {}
    }
  ]
}

Affected browser(s)

All tested.

@sebastianbochan

This comment has been minimized.

Show comment
Hide comment
@sebastianbochan

sebastianbochan Apr 26, 2017

Contributor

I recreated your chart as live demo (http://jsfiddle.net/bm33s2wm/) but unfortunately was not able to replicate your issue. Could you simplify your chart and update my code with yours to introduce the problem? It will allow us to debug and find a reason.

Contributor

sebastianbochan commented Apr 26, 2017

I recreated your chart as live demo (http://jsfiddle.net/bm33s2wm/) but unfortunately was not able to replicate your issue. Could you simplify your chart and update my code with yours to introduce the problem? It will allow us to debug and find a reason.

@goodforenergy

This comment has been minimized.

Show comment
Hide comment
@goodforenergy

goodforenergy Apr 27, 2017

Hi @sebastianbochan. I was able to reproduce the bug by adding some settings - see http://jsfiddle.net/bm33s2wm/1/.

It seems adding a background property to the pane setting is enough to trigger the bug.

goodforenergy commented Apr 27, 2017

Hi @sebastianbochan. I was able to reproduce the bug by adding some settings - see http://jsfiddle.net/bm33s2wm/1/.

It seems adding a background property to the pane setting is enough to trigger the bug.

@sebastianbochan

This comment has been minimized.

Show comment
Hide comment
@sebastianbochan

sebastianbochan Apr 27, 2017

Contributor

Internal note
Fails since a392661

Contributor

sebastianbochan commented Apr 27, 2017

Internal note
Fails since a392661

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment