Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Heatmap + boost.js + no-data-to-display.js + some data = some data + no data to display #6664

Closed
yoisel opened this issue May 1, 2017 · 1 comment
Labels

Comments

@yoisel
Copy link

@yoisel yoisel commented May 1, 2017

I am using heatmap with boost and the module no-data-to-display.js.
I am adding some partial data to my heatmap, my data shows up just fine, but the message "no data to display" is showing up as well.

Expected behaviour

When adding data to the heatmap, the message "no data to display" should be removed

Actual behaviour

The message "no data to display" is showing up together with the data

Live demo with steps to reproduce

https://jsfiddle.net/63u7qtmk/

Affected browser(s)

Tested on:
-Chrome 58 + Windows 10
-MS Edge

Fix proposal:

Inside no-data-to-display,js I changed the line:

each(['pie', 'gauge', 'waterfall', 'bubble', 'treemap'], function(type) { 
    if (seriesTypes[type]) { // ...

into

each(['pie', 'gauge', 'waterfall', 'bubble', 'treemap', 'heatmap'], function(type) {
    if (seriesTypes[type]) { // ...

This seems to fix the issue.

@TorsteinHonsi
Copy link
Collaborator

@TorsteinHonsi TorsteinHonsi commented May 5, 2017

Sorry for the late reply, and thanks for pointing to the problem.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants