New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Highmaps] Shifted legend from the corner #6686

Closed
piotrbarandeveloper opened this Issue May 5, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@piotrbarandeveloper

piotrbarandeveloper commented May 5, 2017

Expected behaviour

The legend should appear at the corner.

Actual behaviour

The legend is shifted from the corner. This happens when my application includes the heatmap module. In the application I use both the map module and the heatmap module.

Live demo with steps to reproduce

http://jsfiddle.net/m9318og1/10/ (with heatmap module)
http://jsfiddle.net/m9318og1/9/ (without heatmap module)

Affected browser(s)

Chrome 58.0.3029.96 (64-bit)
Firefox 53.0
Edge 38.14393.1066.0

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi May 8, 2017

Collaborator

Thanks for writing!

Heatmaps are included in Highmaps, so there is no need to include both.

Collaborator

TorsteinHonsi commented May 8, 2017

Thanks for writing!

Heatmaps are included in Highmaps, so there is no need to include both.

@larrydahooster

This comment has been minimized.

Show comment
Hide comment
@larrydahooster

larrydahooster May 24, 2017

I am getting this error with the following modules I use:

import Highcharts from 'highcharts';
import highchartsFunnel from 'highcharts/modules/funnel';
import highchartsMore from 'highcharts/highcharts-more';
import highchartsSolidGauge from 'highcharts/modules/solid-gauge';
import highmaps from 'highcharts/modules/map';


highchartsMore(Highcharts);
highchartsFunnel(Highcharts);
highchartsSolidGauge(Highcharts);
highmaps(Highcharts);

I am getting the error cause both highcharts-more and map add the series type 'bubble' and 'scatter'. How am I supposed to get rid of the error, when I need both modules, but they are using overlapping seriesTypes?

larrydahooster commented May 24, 2017

I am getting this error with the following modules I use:

import Highcharts from 'highcharts';
import highchartsFunnel from 'highcharts/modules/funnel';
import highchartsMore from 'highcharts/highcharts-more';
import highchartsSolidGauge from 'highcharts/modules/solid-gauge';
import highmaps from 'highcharts/modules/map';


highchartsMore(Highcharts);
highchartsFunnel(Highcharts);
highchartsSolidGauge(Highcharts);
highmaps(Highcharts);

I am getting the error cause both highcharts-more and map add the series type 'bubble' and 'scatter'. How am I supposed to get rid of the error, when I need both modules, but they are using overlapping seriesTypes?

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi May 26, 2017

Collaborator

I'm sorry, you're right. We didn't anticipate this. Since the error message is not critical (just meant for guidance), I'll remove it.

Live demo: http://jsfiddle.net/9j9hqf8L/1/

Collaborator

TorsteinHonsi commented May 26, 2017

I'm sorry, you're right. We didn't anticipate this. Since the error message is not critical (just meant for guidance), I'll remove it.

Live demo: http://jsfiddle.net/9j9hqf8L/1/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment