New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Flag series markers do not display text with the latest release(v5.0.12) #6764

Closed
bb-jessePinkman opened this Issue May 24, 2017 · 14 comments

Comments

Projects
None yet
10 participants
@bb-jessePinkman

bb-jessePinkman commented May 24, 2017

Hey everyone, I'm currently using react-native-highcharts component to create interactive charts(Timeseries using highstocks), we were making use of flags/flag-series/flag-markers to display some information, as of today, they weren't displaying anything on click. The component react-native-highcharts uses online libraries, i.e from code.highcharts.com , and I noticed after changing the src to point to older release(4.2.2), the flags displayed the text fine.

I checked the change logs, might have missed something, please update if its a bug or something has been changed. Thanks.

Expected behaviour

Should display text when clicked upon.

Actual behaviour

Nothing is display when clicked upon.

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus May 25, 2017

Contributor

Sorry, the title was misleading. I thought you mean tooltip doesn't show up.

Demo with this issue: http://jsfiddle.net/gh/get/library/pure/highcharts/highcharts/tree/master/samples/stock/demo/flags-general/

Edit: regression from 5c3ab4f

Contributor

pawelfus commented May 25, 2017

Sorry, the title was misleading. I thought you mean tooltip doesn't show up.

Demo with this issue: http://jsfiddle.net/gh/get/library/pure/highcharts/highcharts/tree/master/samples/stock/demo/flags-general/

Edit: regression from 5c3ab4f

@pawelfus pawelfus added Regression and removed Cant reproduce labels May 25, 2017

@h3adache

This comment has been minimized.

Show comment
Hide comment
@h3adache

h3adache May 25, 2017

Hi @pawelfus. I noticed this as well but why is this marked as Can't reproduce? The fiddle you linked shows the exact issue. Flag series text don't show up.

h3adache commented May 25, 2017

Hi @pawelfus. I noticed this as well but why is this marked as Can't reproduce? The fiddle you linked shows the exact issue. Flag series text don't show up.

@h3adache

This comment has been minimized.

Show comment
Hide comment
@h3adache

h3adache May 25, 2017

Dropping to 5.0.11 makes them appear again.

h3adache commented May 25, 2017

Dropping to 5.0.11 makes them appear again.

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus May 26, 2017

Contributor

Hi, it's not marked as Can't reproduce. Flag was added and removed, my mistake, sorry.

Contributor

pawelfus commented May 26, 2017

Hi, it's not marked as Can't reproduce. Flag was added and removed, my mistake, sorry.

@h3adache

This comment has been minimized.

Show comment
Hide comment
@h3adache

h3adache May 26, 2017

Apologies, my fault. Read it wrong.

h3adache commented May 26, 2017

Apologies, my fault. Read it wrong.

@pldilley

This comment has been minimized.

Show comment
Hide comment
@pldilley

pldilley May 26, 2017

The mouse events are broken too in 5.0.12.

pldilley commented May 26, 2017

The mouse events are broken too in 5.0.12.

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus May 26, 2017

Contributor

You are right. For now, please use v5.0.11.

Contributor

pawelfus commented May 26, 2017

You are right. For now, please use v5.0.11.

@ff-sgupta

This comment has been minimized.

Show comment
Hide comment
@ff-sgupta

ff-sgupta Jun 1, 2017

When is the next release for this fix?

ff-sgupta commented Jun 1, 2017

When is the next release for this fix?

@pawelfus

This comment has been minimized.

Show comment
Hide comment
@pawelfus

pawelfus Jun 5, 2017

Contributor

Hi @ff-sgupta

We don't have ETA for this issue, but I think it will be fixed in the next release.

Contributor

pawelfus commented Jun 5, 2017

Hi @ff-sgupta

We don't have ETA for this issue, but I think it will be fixed in the next release.

jon-a-nygaard added a commit that referenced this issue Jun 14, 2017

Fixed #6764, fixed #6791, fixed #6808, addition #6687. Series with no…
…SharedTooltip was unaccessible when tooltip is shared.

@jon-a-nygaard jon-a-nygaard added this to the 5.0.13 milestone Jun 14, 2017

@ff-skundalkar

This comment has been minimized.

Show comment
Hide comment
@ff-skundalkar

ff-skundalkar Jun 20, 2017

Can you please let us know when can we get this fix ? This is impacting us and have an feature in escalation currently. Can you provide a hot fix to us ?

ff-skundalkar commented Jun 20, 2017

Can you please let us know when can we get this fix ? This is impacting us and have an feature in escalation currently. Can you provide a hot fix to us ?

@TorsteinHonsi

This comment has been minimized.

Show comment
Hide comment
@TorsteinHonsi

TorsteinHonsi Jun 20, 2017

Collaborator

The new release will be out within a few weeks. Until then, you can apply this to the source code: 46738ea

Collaborator

TorsteinHonsi commented Jun 20, 2017

The new release will be out within a few weeks. Until then, you can apply this to the source code: 46738ea

@FlorianBurgevin

This comment has been minimized.

Show comment
Hide comment
@FlorianBurgevin

FlorianBurgevin Aug 3, 2017

Version 5.0.14 is here but this bugs seems to be still there :(

FlorianBurgevin commented Aug 3, 2017

Version 5.0.14 is here but this bugs seems to be still there :(

@KacperMadej

This comment has been minimized.

Show comment
Hide comment
@KacperMadej

KacperMadej Aug 3, 2017

Contributor

@FlorianBurgevin Looks fine for me: http://jsfiddle.net/gh/get/library/pure/highcharts/highcharts/tree/master/samples/stock/demo/flags-general/

Do you have another demo that could show the problem?

Please try to make sure that newer version of Highcharts is loaded.

Contributor

KacperMadej commented Aug 3, 2017

@FlorianBurgevin Looks fine for me: http://jsfiddle.net/gh/get/library/pure/highcharts/highcharts/tree/master/samples/stock/demo/flags-general/

Do you have another demo that could show the problem?

Please try to make sure that newer version of Highcharts is loaded.

@FlorianBurgevin

This comment has been minimized.

Show comment
Hide comment
@FlorianBurgevin

FlorianBurgevin Aug 3, 2017

My bad sorry !
The newer version was not loaded correctly

FlorianBurgevin commented Aug 3, 2017

My bad sorry !
The newer version was not loaded correctly

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment