Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

3d pie drillDown issue #7649

Closed
ManeshM opened this issue Jan 11, 2018 · 16 comments
Closed

3d pie drillDown issue #7649

ManeshM opened this issue Jan 11, 2018 · 16 comments

Comments

@ManeshM
Copy link

@ManeshM ManeshM commented Jan 11, 2018

Hi,

I am facing an issue with 3d pie drilldown chart. Below are the details to replicate it.

  1. Draw 3d pie drillDown chart. Or use jsfiddle to check the chart - http://jsfiddle.net/fL4pm9tq/2/
  2. Click drilldown for "Firefox-10.4%"
  3. The slice for some are shown and some are not shown (color not shown). Please see this link :http://jsfiddle.net/jv6Lh3e7/1/

Can you please let know any solution for this issue?

@KacperMadej
Copy link
Contributor

@KacperMadej KacperMadej commented Jan 11, 2018

Hi @ManeshM

Thank you for reporting about the problem.
It's caused by hovering over slices that are running animation, so a duplicate of #7097

If you disagree, please add more info and the issue could be reopened.

Loading

@ManeshM
Copy link
Author

@ManeshM ManeshM commented Jan 15, 2018

Can you please let me know when this bug will be fixed?

Loading

@ManeshM
Copy link
Author

@ManeshM ManeshM commented Jan 15, 2018

Can you please let me know the status on this bug? Or is there any other temporary solution/work around for this bug?

Loading

@pawelfus
Copy link
Contributor

@pawelfus pawelfus commented Jan 15, 2018

I think this is different issue, not a duplicate of #7097

It used to work in 5.0.12: http://jsfiddle.net/jv6Lh3e7/3/ so it's a regression.

Internal note:
Issue by commit points to: 222eae0 - it's a first commit after 5.0.12 release.

Loading

@ManeshM
Copy link
Author

@ManeshM ManeshM commented Jan 16, 2018

When I try using highstock 6.0.4, this bug still shows up. Could it be that the bug fix isn't there in highstock? We use highstock as we need specific charts other than that offered by highcharts.js

Loading

@pawelfus
Copy link
Contributor

@pawelfus pawelfus commented Jan 16, 2018

No @ManeshM, it's not bug directly in Highstock, in general it's a regression bug introduced in v5.0.13, so all later versions, including v6, have this bug.

Loading

@TorsteinHonsi
Copy link
Collaborator

@TorsteinHonsi TorsteinHonsi commented Jan 23, 2018

Workaround

Disable chart.animation, while keeping the default drilldown.animation: http://jsfiddle.net/highcharts/fL4pm9tq/3/

Loading

@nealdav
Copy link

@nealdav nealdav commented Feb 26, 2018

Wondering if there has been any progress on this bug as well?

I tried reverting to 5.0.12 but that reintroduced the bug from #6882. Disabling chart.animation appears to work but doesn't scale well for me.

Loading

@pawelfus
Copy link
Contributor

@pawelfus pawelfus commented Feb 27, 2018

Hi @nealdav
Could you provide details about the workaround and issues? Note: workaround should be used only for a chart that is a 3d-pie chart.

Loading

@ManeshM
Copy link
Author

@ManeshM ManeshM commented May 2, 2018

sorry. reffer this link http://jsfiddle.net/jv6Lh3e7/3/

Loading

@pawelfus
Copy link
Contributor

@pawelfus pawelfus commented May 2, 2018

Hi @ManeshM - could you check your jsFiddle? It looks fine. Updated demo to use Highstock v5: http://jsfiddle.net/BlackLabel/jv6Lh3e7/35/ - I'm not sure about treemap part, could you elaborate? Thanks!

Loading

@ManeshM
Copy link
Author

@ManeshM ManeshM commented May 2, 2018

When we use treemap and gauge chart (highcharts) with Highstock v5, it will not work (treemap doesn't even load).

Loading

@pawelfus
Copy link
Contributor

@pawelfus pawelfus commented May 2, 2018

@ManeshM - could you update my demo to recreate issue? Take a look: https://jsfiddle.net/BlackLabel/bcgxpzkh/1/ - thanks!

Loading

@ManeshM
Copy link
Author

@ManeshM ManeshM commented May 3, 2018

please reffer this link : - https://jsfiddle.net/bcgxpzkh/2/

5.0.12 this version not supporting gauge charts.

Loading

@pawelfus
Copy link
Contributor

@pawelfus pawelfus commented May 4, 2018

@ManeshM - you have mismatching version of solid gauge and Highstock. Module should be loaded with the same version as main core: https://jsfiddle.net/BlackLabel/bcgxpzkh/3/

Loading

@KacperMadej
Copy link
Contributor

@KacperMadej KacperMadej commented Aug 7, 2018

@TorsteinHonsi

The fix from #7097 is resolving the problem reported here (bisected to confirm), but at the same time shows an error on drillup.

Demo: http://jsfiddle.net/BlackLabel/jv6Lh3e7/37/

Steps:

  1. Drill down
  2. Drill up
  3. Error in console Uncaught InvalidCharacterError: Failed to execute 'setAttribute' on 'Element': '5imgm83' is not a valid attribute name.

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants