Permalink
Browse files

Fix Travis failure by specifying Capybara version

Capybara 2.1.0 requires 1.9.3+ so we install a version that works with every
Ruby version we test against. This can be removed if we stop testing against
1.9.2.

The non-development dependencies are unchanged.
  • Loading branch information...
1 parent b396bfb commit 589d64386c853c2cb0a8ff83053f32c61dbdd7e0 @gabebw gabebw committed Apr 12, 2013
Showing with 4 additions and 4 deletions.
  1. +0 −4 .travis.yml
  2. +4 −0 fake_braintree.gemspec
View
4 .travis.yml
@@ -3,10 +3,6 @@ rvm:
- 1.9.3
before_install:
- gem update --system
- # Capybara 2.1.0 requires 1.9.3+ so we install a version that works with
- # every Ruby version we test against. This can be removed if we stop testing
- # against 1.9.2.
- - gem install capybara -v '< 2.1.0'
branches:
only:
- master
View
4 fake_braintree.gemspec
@@ -25,6 +25,10 @@ Gem::Specification.new do |s|
s.add_dependency 'thin'
s.add_development_dependency 'rspec', '~> 2.12.0'
+ # Capybara 2.1.0 requires 1.9.3+ so we install a version that works with
+ # every Ruby version we test against. This can be removed if we stop testing
+ # against 1.9.2.
+ s.add_development_dependency 'capybara', '~> 2.0.3'
s.add_development_dependency 'bourne', '~> 1.3'
s.add_development_dependency 'timecop', '~> 0.6'
s.add_development_dependency 'rake'

0 comments on commit 589d643

Please sign in to comment.