Skip to content
Browse files

Initial vaporware

  • Loading branch information...
0 parents commit 7890e1d7862d4450fa813671a385143571ee4cd8 @alindeman alindeman committed Feb 17, 2012
Showing with 78 additions and 0 deletions.
  1. +17 −0 .gitignore
  2. +4 −0 Gemfile
  3. +35 −0 README.md
  4. +2 −0 Rakefile
  5. +20 −0 hbase-rb.gemspec
  6. 0 lib/hbase-rb.rb
17 .gitignore
@@ -0,0 +1,17 @@
+*.gem
+*.rbc
+.bundle
+.config
+.yardoc
+Gemfile.lock
+InstalledFiles
+_yardoc
+coverage
+doc/
+lib/bundler/man
+pkg
+rdoc
+spec/reports
+test/tmp
+test/version_tmp
+tmp
4 Gemfile
@@ -0,0 +1,4 @@
+source 'http://rubygems.org'
+
+# Specify your gem's dependencies in hbase-rb.gemspec
+gemspec
35 README.md
@@ -0,0 +1,35 @@
+# HBase For Ruby Made Easy
+
+<!--[![Build Status](https://secure.travis-ci.org/highgroove/hbase-rb.png)](http://travis-ci.org/highgroove/hbase-rb)-->
+
+To use [HBase](http://hbase.apache.org/) with [Apache
+Thrift](http://thrift.apache.org/), you might have to manually generate
+Ruby code from generic *.thrift files.
+
+This gem tries to alleviate that slight annoyance and package everything
+you need to communicate with HBase.
+
+## Installation
+
+### Bundler
+
+Add to `Gemfile` and run `bundle install`:
+
+```ruby
+gem 'hbase-rb'
+```
+
+### Without Bundler
+
+Install the gem:
+
+```bash
+gem install hbase-rb
+```
+
+Require it explicitly in your scripts:
+
+```ruby
+require "rubygems"
+require "hbase-rb"
+```
2 Rakefile
@@ -0,0 +1,2 @@
+#!/usr/bin/env rake
+require "bundler/gem_tasks"
20 hbase-rb.gemspec
@@ -0,0 +1,20 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = "hbase-rb"
+ s.version = "0.0.0"
+ s.authors = ["Andy Lindeman"]
+ s.email = ["andy@highgroove.com"]
+ s.homepage = "http://github.com/highgroove/hbase-rb"
+ s.summary = %q{Generated HBase Thrift bindings for Ruby packed into a gem}
+ s.description = %q{Everything you need to build a Ruby client for HBase}
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+
+ s.add_dependency "thrift", ">=0.7.0"
+
+ s.add_development_dependency "rake"
+end
0 lib/hbase-rb.rb
No changes.

0 comments on commit 7890e1d

Please sign in to comment.
Something went wrong with that request. Please try again.