Skip to content


Subversion checkout URL

You can clone with
Download ZIP


relax the dependency on heroku #20

merged 1 commit into from

3 participants


Heroku bumped the version of their gem to 2.1.3.
And their internal gems are depending on that version.
Ie. pgbackups requires heroku > 2.1.2

Currently hirefire has a fairly strict dependency on heroku (~> 2.0.0).
Hirefire uses a total of 3 methods from the heroku gem api:

  • Client.initialize
  • Client.set_workers

These methods haven't changed since heroku version 1.4. I propose to loosen the dependency to >= 1.4.
In the unlikely event that the api will change, the requirement can be clamped to something alng the lines of [">= 1.4", "< 3"]




We can do that. Thanks for pointing that out. It seems that Heroku updates their gem extremely often apparently, lol -

Merging it in so people can leverage other versions for their needs.

@meskyanichi meskyanichi merged commit 391c0f0 into hirefire:develop

thanks for merging

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on May 13, 2011
  1. @igorbernstein
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  hirefire.gemspec
2  hirefire.gemspec
@@ -24,7 +24,7 @@ do |gem|
# Production gem dependencies
- gem.add_dependency 'heroku', ['~> 2.0.0']
+ gem.add_dependency 'heroku', ['>= 1.4']
gem.add_dependency 'rush', ['~> 0.6.7']
Something went wrong with that request. Please try again.