New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Spaces in bars and glitchy tree menu #813

Open
FireController1847 opened this Issue Jul 11, 2018 · 7 comments

Comments

Projects
None yet
3 participants
@FireController1847

FireController1847 commented Jul 11, 2018

I haven't been able to find anything on this issue so I think I should report it. I'm using PuTTy over an Ubuntu 18.04 server.

When I run htop, it shows all of the bars and processes but it doesn't show them correctly. Here's an image.
image

And as you can see here the currently highlighted option is not centred with the bars at the top.
image

@hishamhm

This comment has been minimized.

Show comment
Hide comment
@hishamhm

hishamhm Jul 28, 2018

Owner

Hi! Thanks for reporting. What is the value of your TERM environment variable (echo $TERM) before you start htop?

Owner

hishamhm commented Jul 28, 2018

Hi! Thanks for reporting. What is the value of your TERM environment variable (echo $TERM) before you start htop?

@FireController1847

This comment has been minimized.

Show comment
Hide comment
@FireController1847

FireController1847 Jul 28, 2018

Here's the response

x@x:~$ echo $TERM
xterm

FireController1847 commented Jul 28, 2018

Here's the response

x@x:~$ echo $TERM
xterm
@khubenbecker

This comment has been minimized.

Show comment
Hide comment
@khubenbecker

khubenbecker Jul 29, 2018

https://askubuntu.com/questions/1060428/htop-display-broken-faulty

I have the problem that since I've upgraded to Ubuntu 18.04 is right after the start (2nd frame) of htop the display broken / faulty.

Here is the issue:

The problem is on several servers, which I have tried:

  • Upgrade / Purge / Reinstall
  • Try other terminals and computers
  • I have several old versions tried with the same problem: 1.0 / 2.0.0 / 2.0.1 / 2.0.1 / 2.1.0 / 2.2.0 (self build)

$echo $TERM
xterm

Best regards

khubenbecker commented Jul 29, 2018

https://askubuntu.com/questions/1060428/htop-display-broken-faulty

I have the problem that since I've upgraded to Ubuntu 18.04 is right after the start (2nd frame) of htop the display broken / faulty.

Here is the issue:

The problem is on several servers, which I have tried:

  • Upgrade / Purge / Reinstall
  • Try other terminals and computers
  • I have several old versions tried with the same problem: 1.0 / 2.0.0 / 2.0.1 / 2.0.1 / 2.1.0 / 2.2.0 (self build)

$echo $TERM
xterm

Best regards

@FireController1847

This comment has been minimized.

Show comment
Hide comment
@FireController1847

FireController1847 Jul 29, 2018

I can agree this started when upgrading from 16.04 to 18.04

FireController1847 commented Jul 29, 2018

I can agree this started when upgrading from 16.04 to 18.04

@khubenbecker

This comment has been minimized.

Show comment
Hide comment
@khubenbecker

khubenbecker Jul 29, 2018

The problem is with the Terminal Type when switching from xterm to linux, then the problem is solved.

But you have to know first, if you never had problems with it :)

khubenbecker commented Jul 29, 2018

The problem is with the Terminal Type when switching from xterm to linux, then the problem is solved.

But you have to know first, if you never had problems with it :)

@FireController1847

This comment has been minimized.

Show comment
Hide comment
@FireController1847

FireController1847 Jul 29, 2018

Alright, but that still seems more of a workaround than a solution which means this would be a bug, no? @khubenbecker @hishamhm

FireController1847 commented Jul 29, 2018

Alright, but that still seems more of a workaround than a solution which means this would be a bug, no? @khubenbecker @hishamhm

@FireController1847

This comment has been minimized.

Show comment
Hide comment
@FireController1847

FireController1847 Aug 4, 2018

@hishamhm Any status on this? When using the linux term, I can't seem to use the tree menu at all which was my favorite feature.

FireController1847 commented Aug 4, 2018

@hishamhm Any status on this? When using the linux term, I can't seem to use the tree menu at all which was my favorite feature.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment