New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade to Moodle 2.9 API, use core_text. #23

Open
wants to merge 3 commits into
base: master
from

Conversation

Projects
None yet
1 participant
@michaliskambi

michaliskambi commented Sep 20, 2015

Moodle 2.9 requires using core_text:::xxx functions. Right now entering plagiarism/moss/settings.php page fails with error

textlib_get_instance() can not be used any more, please use core_text::functioname() instead.

Submitting a simple fix. Other Moodle modules applied similar fixes, see e.g. patrickpollet/moodle_local_ldap#9 and jleyva/moodle-local_ltiprovider@9fefa6b .

This fix seems to work fine for our Moodle 2.9.2+ (from 2015-09-18) installation + Moss.

@michaliskambi

This comment has been minimized.

michaliskambi commented Oct 13, 2015

I added another commit to this pull request, that fixed moss_save_storedfiles for Moodle 2.9.

timetomeasure must be set by admin.
It seems that you cannot run moss measure() in any other way --- it is run only from cron, and timetomeasure is set only from admin options. Moss will *not* automatically run on due time. So fix the docs.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment