New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Install Error #494

Closed
SeAL80s opened this Issue Mar 29, 2018 · 31 comments

Comments

Projects
None yet
8 participants
@SeAL80s
Copy link

SeAL80s commented Mar 29, 2018

Observed behavior

just git clone ,then cp init.example.el init.el ,then make install,then the error message came up

Package refresh done
Installing ox-reveal
FATAL ERROR: (error) Need package ‘org-20150330’, but only 9.1.9 is available
Installing centered-window-mode
FATAL ERROR: (error) Package ‘centered-window-mode-’ is unavailable
Installing ob-redis
FATAL ERROR: (error) Package ‘ob-redis-’ is unavailable
Installing auth-password-store
FATAL ERROR: (error) Package ‘auth-password-store-’ is unavailable
Installing help-fns+
FATAL ERROR: (error) Package ‘help-fns+-’ is unavailable
Finished!

Expected behavior

Steps to reproduce

  1. Select these example steps,
  2. Delete them,
  3. And replace them with precise steps to reproduce your issue.

System information

Arch Linux x86_64 emacs 25.3.1
Replace this line with the output of *one* of these commands:

+ `M-x doom/info` (from inside Emacs)
+ `DEBUG=1 make doctor` (command line)

DOOM Doctor
Running Emacs v25.3.1, commit 5dacbb7

shell: /usr/bin/zsh
Compiled with:
XPM JPEG TIFF GIF PNG RSVG IMAGEMAGICK SOUND GPM DBUS GCONF GSETTINGS
NOTIFY ACL GNUTLS LIBXML2 FREETYPE M17N_FLT LIBOTF XFT ZLIB
TOOLKIT_SCROLL_BARS GTK3 X11 MODULES
uname -a:
Linux SeAL80s 4.14.30-1-MANJARO #1 SMP PREEMPT Sun Mar 25 19:47:20 UTC
2018 x86_64 GNU/Linux

Attempt to load DOOM: success! Loaded v2.0.9
Revision 5dacbb7


test-emacs
test-windows
test-fonts
Warning: couldn’t find material-design-icons.ttf font in /home/daniel/.local/share/fonts/
You can install it by running ‘M-x all-the-icons-install-fonts’ within
Emacs.

This could also mean you’ve installed them in non-standard locations,
in which case, ignore this warning.
Warning: couldn’t find weathericons.ttf font in /home/daniel/.local/share/fonts/
You can install it by running ‘M-x all-the-icons-install-fonts’ within
Emacs.

This could also mean you’ve installed them in non-standard locations,
in which case, ignore this warning.
Warning: couldn’t find octicons.ttf font in /home/daniel/.local/share/fonts/
You can install it by running ‘M-x all-the-icons-install-fonts’ within
Emacs.

This could also mean you’ve installed them in non-standard locations,
in which case, ignore this warning.
Warning: couldn’t find fontawesome.ttf font in /home/daniel/.local/share/fonts/
You can install it by running ‘M-x all-the-icons-install-fonts’ within
Emacs.

This could also mean you’ve installed them in non-standard locations,
in which case, ignore this warning.
Warning: couldn’t find file-icons.ttf font in /home/daniel/.local/share/fonts/
You can install it by running ‘M-x all-the-icons-install-fonts’ within
Emacs.

This could also mean you’ve installed them in non-standard locations,
in which case, ignore this warning.
Warning: couldn’t find all-the-icons.ttf font in /home/daniel/.local/share/fonts/
You can install it by running ‘M-x all-the-icons-install-fonts’ within
Emacs.

This could also mean you’ve installed them in non-standard locations,
in which case, ignore this warning.
test-gnutls
test-tls
Validated https://elpa.gnu.org
Validated https://melpa.org
Successfully rejected https://self-signed.badssl.com
Successfully rejected https://wrong.host.badssl.com/
test-tar
Everything seems fine, happy Emacs’ing!

@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Mar 29, 2018

Please switch to develop. These issues have been fixed and are due to be merged into master soon.

Also, please don't close this thread. I'd like to keep it open until develop is merged.

@hlissner hlissner added this to the 2.1 milestone Mar 29, 2018

@liuquanhao

This comment has been minimized.

Copy link

liuquanhao commented Apr 4, 2018

Me too..
When I checkout develop..
Recursive load: "/home/liuxu/.emacs.d/modules/config/private/init.el", "/home/liuxu/.config/doom/init.el", "/home/liuxu/.emacs.d/modules/config/private/init.el", "/home/liuxu/.config/doom/init.el", "/home/liuxu/.emacs.d/modules/config/private/init.el", "/home/liuxu/.config/doom/init.el", "/home/liuxu/.emacs.d/modules/config/private/init.el", "/home/liuxu/.config/doom/init.el", "/home/liuxu/.emacs.d/modules/config/private/init.el", "/home/liuxu/.emacs.d/init.el"
Makefile:92: recipe for target '.local/autoloads.el' failed
make: *** [.local/autoloads.el] Error 255

@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Apr 4, 2018

Are you on the latest develop? The config/private module has been removed and is no longer needed. Delete your ~/.emacs.d/init.el before updating to the latest Doom as it has been replaced with a default one.

@liuquanhao

This comment has been minimized.

Copy link

liuquanhao commented Apr 4, 2018

liuxu:~$ git clone -b develop https://github.com/hlissner/doom-emacs ~/.emacs.dCloning into '/home/liuxu/.emacs.d'...
remote: Counting objects: 33294, done.
remote: Compressing objects: 100% (143/143), done.
remote: Total 33294 (delta 136), reused 180 (delta 106), pack-reused 33044
Receiving objects: 100% (33294/33294), 9.37 MiB | 2.07 MiB/s, done.
Resolving deltas: 100% (23004/23004), done.
Checking connectivity... done.
liuxu:~$ cd .emacs.d/
liuxu:.emacs.d$ git branch -av
* develop                    a582bdf app/calendar: fix typo causing void-variable error
  remotes/origin/HEAD        -> origin/master
  remotes/origin/develop     a582bdf app/calendar: fix typo causing void-variable error
  remotes/origin/master      5dacbb7 Merge branch 'develop'
  remotes/origin/screenshots e2956e5 Add screenshots
liuxu:.emacs.d$ cp init.example.el init.el
liuxu:.emacs.d$ make install
Symbol’s function definition is void: doom!
Makefile:93: recipe for target '.local/autoloads.el' failed
make: *** [.local/autoloads.el] Error 255
@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Apr 4, 2018

cp init.example.el init.el

Change this step to cp init.example.el ~/.doom.d/init.el

Doom now supplies a default init.el that should not be overwritten. The documentation will be updated to reflect this soon.

@liuquanhao

This comment has been minimized.

Copy link

liuquanhao commented Apr 4, 2018

liuxu:~$ git clone -b develop https://github.com/hlissner/doom-emacs ~/.emacs.d
Cloning into '/home/liuxu/.emacs.d'...
remote: Counting objects: 33294, done.
remote: Compressing objects: 100% (143/143), done.
remote: Total 33294 (delta 136), reused 180 (delta 106), pack-reused 33044
Receiving objects: 100% (33294/33294), 9.37 MiB | 2.05 MiB/s, done.
Resolving deltas: 100% (23004/23004), done.
Checking connectivity... done.
liuxu:~$ mkdir .doom.d
liuxu:~$ cd .emacs.d/
liuxu:.emacs.d$ cp init.example.el ~/.doom.d/init.el
liuxu:.emacs.d$ make install
Installing core packages
Importing package-keyring.gpg...
Importing package-keyring.gpg...done
Contacting host: elpa.gnu.org:443
Contacting host: elpa.gnu.org:443
Contacting host: melpa.org:443
Contacting host: melpa.org:443
Contacting host: orgmode.org:443
Contacting host: orgmode.org:443
Package refresh done
✓ Installed persistent-soft
✓ Installed use-package
✓ Installed quelpa
✓ Installed async
Installing core packages...done
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Recursive ‘require’ for feature ‘core’
Makefile:93: recipe for target '.local/autoloads.el' failed
make: *** [.local/autoloads.el] Error 255
@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Apr 4, 2018

Odd, this only occurs if you have this line in ~/.doom.d/init.el:

(require 'core (concat user-emacs-directory "core/core"))

But it was removed from init.example.el in 0026f08 (~7 hours ago). Check to make sure that line is not present in ~/.doom.d/init.el, and delete it if it is.

@liuquanhao

This comment has been minimized.

Copy link

liuquanhao commented Apr 4, 2018

liuxu:.doom.d$ cat init.el | grep "concat"
liuxu:.doom.d$ 
@liuquanhao

This comment has been minimized.

Copy link

liuquanhao commented Apr 4, 2018

liuxu:.doom.d$ pwd
/home/liuxu/.doom.d
liuxu:.doom.d$ cat init.el 
;;; init.example.el -*- lexical-binding: t; -*-

(doom! :feature
       (popup            ; tame sudden yet inevitable temporary windows
        +all             ; catch all popups that start with an asterix
        +defaults)       ; default popup rules
      ;debugger          ; FIXME stepping through code, to help you add bugs
       eval              ; run code, run (also, repls)
       (evil +everywhere); come to the dark side, we have cookies
       file-templates    ; auto-snippets for empty files
       (lookup           ; helps you navigate your code and documentation
        +devdocs         ; ...on devdocs.io online
        +docsets)        ; ...or in Dash docsets locally
       services          ; TODO managing external services & code builders
       snippets          ; my elves. They type so I don't have to
       spellcheck        ; tasing you for misspelling mispelling
       syntax-checker    ; tasing you for every semicolon you forget
       version-control   ; remember, remember that commit in November
       workspaces        ; tab emulation, persistence & separate workspaces

       :completion
       company           ; the ultimate code completion backend
      ;helm              ; the *other* search engine for love and life
      ;ido               ; the other *other* search engine...
       ivy               ; a search engine for love and life

       :ui
       doom              ; what makes DOOM look the way it does
       doom-dashboard    ; a nifty splash screen for Emacs
       doom-modeline     ; a snazzy Atom-inspired mode-line
       doom-quit         ; DOOM quit-message prompts when you quit Emacs
       evil-goggles      ; display visual hints when editing in evil
       hl-todo           ; highlight TODO/FIXME/NOTE tags
       nav-flash         ; blink the current line after jumping
      ;posframe          ; use child frames where possible (Emacs 26+ only)
      ;tabbar            ; FIXME an (incomplete) tab bar for Emacs
      ;unicode           ; extended unicode support for various languages
       vi-tilde-fringe   ; fringe tildes to mark beyond EOB
       window-select     ; visually switch windows

       :tools
       dired             ; making dired pretty [functional]
       electric-indent   ; smarter, keyword-based electric-indent
       eshell            ; a consistent, cross-platform shell (WIP)
       gist              ; interacting with github gists
       imenu             ; an imenu sidebar and searchable code index
       impatient-mode    ; show off code over HTTP
      ;macos             ; MacOS-specific commands
       make              ; run make tasks from Emacs
      ;magit             ;
       neotree           ; a project drawer, like NERDTree for vim
       password-store    ; password manager for nerds
       pdf               ; pdf enhancements
      ;rgb               ; creating color strings
       rotate-text       ; cycle region at point between text candidates
       term              ; terminals in Emacs
       tmux              ; an API for interacting with tmux
       upload            ; map local to remote projects via ssh/ftp

       :lang
       assembly          ; assembly for fun or debugging
       cc                ; C/C++/Obj-C madness
       crystal           ; ruby at the speed of c
       clojure           ; java with a lisp
       csharp            ; unity, .NET, and mono shenanigans
       data              ; config/data formats
       elixir            ; erlang done right
       elm               ; care for a cup of TEA?
       emacs-lisp        ; drown in parentheses
       ess               ; emacs speaks statistics
       go                ; the hipster dialect
       (haskell +intero) ; a language that's lazier than I am
       hy                ; readability of scheme w/ speed of python
       (java +meghanada) ; the poster child for carpal tunnel syndrome
       javascript        ; all(hope(abandon(ye(who(enter(here))))))
       julia             ; a better, faster MATLAB
       latex             ; writing papers in Emacs has never been so fun
       ledger            ; an accounting system in Emacs
       lua               ; one-based indices? one-based indices
       markdown          ; writing docs for people to ignore
       nix               ; I hereby declare "nix geht mehr!"
       ocaml             ; an objective camel
       (org              ; organize your plain life in plain text
        +attach          ; custom attachment system
        +babel           ; running code in org
        +capture         ; org-capture in and outside of Emacs
        +export          ; Exporting org to whatever you want
        +present         ; Emacs for presentations
        +publish)        ; Emacs+Org as a static site generator
       perl              ; write code no one else can comprehend
       php               ; perl's insecure younger brother
       plantuml          ; diagrams for confusing people more
       purescript        ; javascript, but functional
       python            ; beautiful is better than ugly
       rest              ; Emacs as a REST client
       ruby              ; 1.step do {|i| p "Ruby is #{i.even? ? 'love' : 'life'}"}
       rust              ; Fe2O3.unwrap().unwrap().unwrap().unwrap()
       scala             ; java, but good
       sh                ; she sells (ba|z)sh shells on the C xor
       swift             ; who asked for emoji variables?
       typescript        ; javascript, but better
       web               ; the tubes

       ;; Applications are complex and opinionated modules that transform Emacs
       ;; toward a specific purpose. They may have additional dependencies and
       ;; should be loaded late.
       :app
      ;(email +gmail)    ; emacs as an email client
      ;irc               ; how neckbeards socialize
      ;(rss +org)        ; emacs as an RSS reader
      ;twitter           ; twitter client https://twitter.com/vnought
      ;(write            ; emacs as a word processor (latex + org + markdown)
      ; +wordnut         ; wordnet (wn) search
      ; +langtool)       ; a proofreader (grammar/style check) for Emacs

       :config
       ;; The default module set reasonable defaults for Emacs. It also provides
       ;; a Spacemacs-inspired keybinding scheme, a custom yasnippet library,
       ;; and additional ex commands for evil-mode. Use it as a reference for
       ;; your own modules.
       (default +bindings +snippets +evil-commands))

liuxu:.doom.d$ 
@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Apr 4, 2018

Is ~/.doom.d empty besides the init.el?

Have you byte-compiled ~/.emacs.d (with make compile)?

@liuquanhao

This comment has been minimized.

Copy link

liuquanhao commented Apr 4, 2018

liuxu:~$ rm -rf .emacs.d/ .doom.d/
liuxu:~$ mkdir .doom.d
liuxu:~$ git clone -b develop https://github.com/hlissner/doom-emacs ~/.emacs.d
Cloning into '/home/liuxu/.emacs.d'...
remote: Counting objects: 33309, done.
remote: Compressing objects: 100% (153/153), done.
remote: Total 33309 (delta 145), reused 190 (delta 111), pack-reused 33044
Receiving objects: 100% (33309/33309), 9.38 MiB | 1.97 MiB/s, done.
Resolving deltas: 100% (23013/23013), done.
Checking connectivity... done.
liuxu:~$ cd .emacs.d/
liuxu:.emacs.d$ cp init.example.el ~/.doom.d/init.el
liuxu:.emacs.d$ git branch -av
* develop                    0e12761 Update README with new make quickstart workflow
  remotes/origin/HEAD        -> origin/master
  remotes/origin/develop     0e12761 Update README with new make quickstart workflow
  remotes/origin/master      5dacbb7 Merge branch 'develop'
  remotes/origin/screenshots e2956e5 Add screenshots
liuxu:.emacs.d$ ls -al ~/.doom.d/
total 16
drwxrwxr-x  2 liuxu liuxu 4096 4月   4 18:30 .
drwxr-xr-x 46 liuxu liuxu 4096 4月   4 18:30 ..
-rw-rw-r--  1 liuxu liuxu 6521 4月   4 18:30 init.el
liuxu:.emacs.d$ make install
Installing core packages
Importing package-keyring.gpg...
Importing package-keyring.gpg...done
Contacting host: elpa.gnu.org:443
Contacting host: elpa.gnu.org:443
Contacting host: melpa.org:443
Contacting host: melpa.org:443
Contacting host: orgmode.org:443
Package refresh done
✓ Installed persistent-soft
✓ Installed use-package
✓ Installed quelpa
✓ Installed async
Installing core packages...done
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Warning: Eager macro-expansion skipped due to cycle:
  … => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")
Recursive ‘require’ for feature ‘core’
Makefile:97: recipe for target '.local/autoloads.el' failed
make: *** [.local/autoloads.el] Error 255
liuxu:.emacs.d$
`
@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Apr 4, 2018

I cannot reproduce this. Do you have a ~/.config/doom folder, by chance? In which you might possibly have an init.el that calls (require 'core (concat user-emacs-directory "core/core"))?

~/.config/doom is used instead of ~/.doom.d if it is detected.

@liuquanhao

This comment has been minimized.

Copy link

liuquanhao commented Apr 4, 2018

Haha,I install success.I am Ubuntu16.04,all configs in ~/.config/.Thank you ~

@SeAL80s

This comment has been minimized.

Copy link
Author

SeAL80s commented Apr 13, 2018

now in emacs 25.3.3 with Arch Linux x86_64 . in doom-emacs master still has the problem :
FATAL ERROR: (error) Need package ‘org-20150330’, but only 9.1.9 is available
FATAL ERROR: (error) Package ‘centered-window-mode-’ is unavailable
FATAL ERROR: (error) Package ‘ob-redis-’ is unavailable

and in develop branch
screenshot_2018-04-13_11-37-31
do not have the cool UI ,nothing .but it says "Doom loaded 123 packages across 0 modules in 0.585s"

@mbark

This comment has been minimized.

Copy link

mbark commented Apr 13, 2018

@SeAL80s did you run make before starting emacs on the develop branch?

@SeAL80s

This comment has been minimized.

Copy link
Author

SeAL80s commented Apr 13, 2018

@mbark In the Master branch 'make install ' will produce

"FATAL ERROR: (error) Need package ‘org-20150330’, but only 9.1.9 is available"

git checkout develop then make (or make install ) It appears like above , no color UI and It's just 44 packages installed . In the Master Branch It's 300+ .

And ,If 'make install ' in master branch ,then checkout develop , 'make' will remove 250+ packages ,remain 44 packages.

If git clone doom-emacs , then cp init.example.el init.el (in develop branch ,there is a init.el already) , 'make install ' will produce Error 'Symbol’s function definition is void: doom!'

@fuxialexander

This comment has been minimized.

Copy link

fuxialexander commented Apr 13, 2018

@SeAL80s The correct flow is

  1. clone doom-emacs
  2. cd ~/.emacs.d && git checkout develop
  3. mkdir ~/.doom.d && cp ~/.emacs.d/init.example.el ~/.doom.d/init.el
  4. cd ~/.emacs.d && make install
@SeAL80s

This comment has been minimized.

Copy link
Author

SeAL80s commented Apr 13, 2018

@fuxialexander I just found myself . Turn out ,the develop branch require ~/.doom.d/ and copy init.example.el to ~/.doom.d/ . So i did just like you wtire above ,and it works .(It's not in the README, or website ,it's in develop branch's init.example.el )

@mbark

This comment has been minimized.

Copy link

mbark commented Apr 13, 2018

@SeAL80s @hlissner has mentioned in some other issues that the docs will be updated and that it is part of the next release.

@SeAL80s

This comment has been minimized.

Copy link
Author

SeAL80s commented May 6, 2018

@hlissner In the develop branch there is a init.el in .emacs.d calls (require 'core (concat user-emacs-directory "core/core")) which cause @liuxuzzz problem . My solution is in the master branch ,

mkdir ~/.doom.d ,cp init.example.el ~/.doom.d/init.el

then

git checkout develop

switch to develop branch

mv ~/.doom.d/init.el ~/.emacs.d/init.el

to overwrite the default init.el in develop branch ,which contain only one line

(require 'core (concat user-emacs-directory "core/core"))

Then "make instal"l works perfectly .

@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented May 6, 2018

@SeAL80s The order is incorrect. Please do not use init.example.el from the master branch if you intend to use develop. This will cause problems. I highly recommend you do not modify or replace ~/.emacs.d/init.el unless you understand the repercussions of doing so.

  • ~/.emacs.d/init.el should only contain (require 'core (concat user-emacs-directory "core/core"))
  • ~/.doom.d/init.el should not contain (require 'core (concat user-emacs-directory "core/core"))

This is all you need to install Doom:

On master

git clone https://github.com/hlissner/doom-emacs ~/.emacs.d
cd ~/.emacs.d
cp init.example.el init.el
make install

On develop (recommended)

git clone https://github.com/hlissner/doom-emacs ~/.emacs.d
cd ~/.emacs.d
mkdir ~/.doom.d
cp init.example.el ~/.doom.d/init.el
make install
@SeAL80s

This comment has been minimized.

Copy link
Author

SeAL80s commented May 6, 2018

@hlissner But Your order doesn't for me . On master there is this error

FATAL ERROR: (error) Need package ‘org-20150330’, but only 9.1.9 is available

and On develop cp init.example.el init.el , then 'make install' will show ":doom is invalid " .
The order i mentioned works for me . I don't know why , but 'make install' will sucess .
By the way ,on develop there is already has a init.el ,if cp init.example.el ~/.doom.d/init.el will show

Warning: Eager macro-expansion skipped due to cycle:
… => (load "core.el") => (macroexpand-all …) => (macroexpand (eval-and-compile …)) => (load "init.el") => (load "core.el")
Eager macro-expansion failure: (error "Recursive ‘require’ for feature ‘core’")

@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented May 6, 2018

On master there is this error...

Yes, you are correct. I forget, master is currently broken.

On develop cp init.example.el init.el, then...

cp init.example.el init.el is incorrect.

cp ~/.emacs.d/init.example.el ~/.doom.d/init.el is correct.

On develop there is already has a init.el

This is correct. It should not be modified. ~/.emacs.d/init.el should only contain:

(require 'core (concat user-emacs-directory "core/core"))

The above line must not be inside ~/.doom.d/init.el! Or you get that error.

As I said before, do cp ~/.emacs.d/init.example.el ~/.doom.d/init.el.

@jameskolce

This comment has been minimized.

Copy link

jameskolce commented May 15, 2018

Hi @hlissner
I just made a fresh install of Emacs 26.1 but was getting errors when installing Doom, so I found this issue and followed the next steps:

git clone https://github.com/hlissner/doom-emacs ~/.emacs.d
cd ~/.emacs.d
git checkout develop
mkdir ~/.doom.d
cp init.example.el ~/.doom.d/init.el
make install

but I still get:

.emacs.d ) make install

Symbol's function definition is void: advice-add
make: *** [.local/autoloads.el] Error 255

Any advice?
Thanks.

@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented May 15, 2018

@jameskolce Make sure that the emacs you have in your PATH is the correct one. If advice-add is undefined, that implies an earlier version of Emacs (24 or under) is running.

Run emacs --version in your shell to find out.

@jameskolce

This comment has been minimized.

Copy link

jameskolce commented May 16, 2018

@hlissner Thanks! I found the problem: emacs --version was returning the right version (26.1) so I didn't know what could be the problem, but at the end it was indeed trying to use Emacs 22 as you mention, because I had made a command alias instead of a link. It's working now, thanks.

@BenJWard

This comment has been minimized.

Copy link

BenJWard commented May 24, 2018

I'm having issues on develop in particular with emacs-snippets, and php-extras:

N82106:.emacs.d bward$ make install
Looking for packages to install...
2 packages will be installed:

+ emacs-snippets (QUELPA)
+ php-extras (QUELPA)

Proceed? (y or n) y
Installing php-extras
✕ ERROR ((wrong-type-argument arrayp nil))
Installing emacs-snippets
✕ ERROR ((wrong-type-argument arrayp nil))
Finished!

I used process

git clone https://github.com/hlissner/doom-emacs ~/.emacs.d
cd ~/.emacs.d
git checkout develop
mkdir ~/.doom.d
cp init.example.el ~/.doom.d/init.el
make install
@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Jun 2, 2018

@BenJWard I've been hunting for this bug for a while now, but still haven't come up with any leads. Would you be able to recreate the error with DEBUG=1 make install, then copy the resulting backtrace (as much of it as you can) into a pastebin to send to me?

@BenJWard

This comment has been minimized.

Copy link

BenJWard commented Jun 7, 2018

@hlissner I've just tried that and it seems to hang in places wherever it says "entering debugger..."

Extracting expand-region-20171217.2125/ruby-mode-expansions.el
Extracting expand-region-20171217.2125/expand-region-custom.el
Extracting expand-region-20171217.2125/latex-mode-expansions.el
Extracting expand-region-20171217.2125/jsp-expansions.el
Extracting expand-region-20171217.2125/js-mode-expansions.el
Extracting expand-region-20171217.2125/expand-region-core.el
Extracting expand-region-20171217.2125/text-mode-expansions.el
Extracting expand-region-20171217.2125/python-el-expansions.el
Extracting expand-region-20171217.2125/the-org-mode-expansions.el
Entering debugger...
@tidux

This comment has been minimized.

Copy link

tidux commented Sep 23, 2018

I see that exact same hang on a fresh install from develop today.

@hlissner

This comment has been minimized.

Copy link
Owner

hlissner commented Sep 23, 2018

I'll close this, since the original issue has been resolved.

@tidux @BenJWard Could you create a new issue for the hang? Please include your M-x doom/info.

@hlissner hlissner closed this Sep 23, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment