Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: master
Fetching contributors…

Cannot retrieve contributors at this time

83 lines (68 sloc) 2.71 kB
Revision history for Task-BeLike-HMA-Toolchain
0.07_02 Aug 01, 2011
- Add Version::Requirements
- Adjust required versions to versions in core
* ExtUtils::Manifest from 1.58 to 1.57
* Module::Build from 0.36 to 0.3603
* Pod::Simple from 3.11 to 3.07
* version.pm from 0.77 to 0.88
- Optimized installation order
- File::Which and File::HomeDir don't depend on Perl 5.8+
- Don't install Pod::Simple, Pod::Man, Pod::Usage on Perl 5.8.0
0.07_01 Jul 25, 2011
- Add optional modules for enhancement of CPAN.pm
* Archive::Zip
* CPAN::Meta
* JSON::PP
* Module::CoreList
* Parse::CPAN::Meta
- Remove YAML::Tiny
0.07 Jul 23, 2011
- FIX: Updating Pod::Man requires Pod::Usage to be updated too
- Don't install CPAN::SQLite under perlbrewed Perls
- Latest YAML::XS (0.35) available again on Perl 5.8.5
- Convert README to Markdown
- Upgrade to Module::Install 1.01
0.06 Jul 15, 2011
- Require Perl::OSType and Module::Metadata for Module::Build 0.36_20+
- Require Scalar::Util 1.18 for YAML::Tiny 1.48+
0.05 Jan 15, 2011
- Add optional modules for enhancement of CPAN.pm
* CPAN::SQLite
* DBD::SQLite
* DBI
- Make more dependencies explicit which latest versions fail
on legacy Perls
* HTML::Parser
* Pod::Simple
* URI
- Require Scalar::Util 1.08 to workaround a bug in YAML::Tiny
(RT #53490)
- Bump YAML::XS to 0.34 and make its installation dependent on
Perl 5.8.8 (RT #62054)
- Don't install YAML::Syck if YAML::XS can be installed
- Disable Encode, File::HomeDir, File::Which, IO::File on 5.6.x
- Disable Storable, YAML::Syck on 5.8.0
- Switch GitHub URLs to https
0.03 Oct 10, 2010
- Made more dependencies explicit for ease of individual update
* Compress::Zlib
* Digest::MD5
* ExtUtils::Manifest
* File::Path
* File::Spec
* Net::FTP
* Test
* version.pm
- Added optional modules for enhancement of CPAN.pm
* File::HomeDir
* File::Which
* Storable
* Text::Glob
- Bumped to more recent versions
* Module::Build and dependencies
* Test::More
- Added YAML::Syck for YAML support in very legacy Perls
- Changed minimum Perl version to 5.6.1
0.01 Sep 11, 2010
- Initial commit and release to GitHub
Jump to Line
Something went wrong with that request. Please try again.