New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add initial Appveyor config #16

Merged
merged 1 commit into from Jul 12, 2017

Conversation

Projects
None yet
2 participants
@paultcochrane
Contributor

paultcochrane commented Jul 9, 2017

Appveyor is effectively the Travis-CI for Windows systems. This patch adds an Appveyor config to the project so that it can be tested automatically under Windows.

I've chosen not to use a shallow git clone since (during testing) I was getting errors about the .git directory not being able to be found, and this seemed to fix the issue. I've also set the StrawberryPerl version to be 5.24, since HTTP::Message::PSGI doesn't install when using 5.26.

Note that the script hangs in much the same way as reported in #3. I've manged to be able to see the compile tests run, but the remaining tests aren't shown, and I'm guessing the output doesn't appear due to buffering, but I suspect that the test run is hanging in the same place as in #3.

Hope this helps in at least some way!

@hoelzro hoelzro merged commit 48b1dc1 into hoelzro:master Jul 12, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@hoelzro

This comment has been minimized.

Show comment
Hide comment
@hoelzro

hoelzro Jul 12, 2017

Owner

Thanks Paul - this should help me deal with the problem!

Owner

hoelzro commented Jul 12, 2017

Thanks Paul - this should help me deal with the problem!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment