Skip to content
Browse files

SPARK-1084.2 (resubmitted)

(Ported from https://github.com/apache/incubator-spark/pull/650 )

This adds one more change though, to fix the scala version warning introduced by json4s recently.

Author: Sean Owen <sowen@cloudera.com>

Closes #32 from srowen/SPARK-1084.2 and squashes the following commits:

9240abd [Sean Owen] Avoid scala version conflict in scalap induced by json4s dependency
1561cec [Sean Owen] Remove "exclude *" dependencies that are causing Maven warnings, and that are apparently unneeded anyway
  • Loading branch information...
1 parent 353ac6b commit fd31adbf27d824f00f62646e13c23f632d1b77d3 @srowen srowen committed with pwendell Mar 2, 2014
Showing with 22 additions and 61 deletions.
  1. +9 −0 core/pom.xml
  2. +0 −8 examples/pom.xml
  3. +0 −4 external/flume/pom.xml
  4. +4 −33 pom.xml
  5. +9 −11 project/SparkBuild.scala
  6. +0 −5 streaming/pom.xml
View
9 core/pom.xml
@@ -125,6 +125,15 @@
<groupId>org.json4s</groupId>
<artifactId>json4s-jackson_${scala.binary.version}</artifactId>
<version>3.2.6</version>
+ <!-- see also exclusion for lift-json; this is necessary since it depends on
+ scala-library and scalap 2.10.0, but we use 2.10.3, and only override
+ scala-library -->
+ <exclusions>
+ <exclusion>
+ <groupId>org.scala-lang</groupId>
+ <artifactId>scalap</artifactId>
+ </exclusion>
+ </exclusions>
</dependency>
<dependency>
<groupId>it.unimi.dsi</groupId>
View
8 examples/pom.xml
@@ -169,14 +169,6 @@
<groupId>org.apache.cassandra.deps</groupId>
<artifactId>avro</artifactId>
</exclusion>
- <exclusion>
- <groupId>org.sonatype.sisu.inject</groupId>
- <artifactId>*</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.xerial.snappy</groupId>
- <artifactId>*</artifactId>
- </exclusion>
</exclusions>
</dependency>
</dependencies>
View
4 external/flume/pom.xml
@@ -53,10 +53,6 @@
<groupId>org.jboss.netty</groupId>
<artifactId>netty</artifactId>
</exclusion>
- <exclusion>
- <groupId>org.xerial.snappy</groupId>
- <artifactId>*</artifactId>
- </exclusion>
</exclusions>
</dependency>
<dependency>
View
37 pom.xml
@@ -310,6 +310,9 @@
<groupId>net.liftweb</groupId>
<artifactId>lift-json_${scala.binary.version}</artifactId>
<version>2.5.1</version>
+ <!-- see also exclusion for json4s; this is necessary since it depends on
+ scala-library and scalap 2.10.0, but we use 2.10.3, and only override
+ scala-library -->
<exclusions>
<exclusion>
<groupId>org.scala-lang</groupId>
@@ -374,7 +377,7 @@
<version>3.1</version>
<scope>test</scope>
</dependency>
- <dependency>
+ <dependency>
<groupId>org.mockito</groupId>
<artifactId>mockito-all</artifactId>
<version>1.8.5</version>
@@ -417,14 +420,6 @@
<artifactId>netty</artifactId>
</exclusion>
<exclusion>
- <groupId>org.codehaus.jackson</groupId>
- <artifactId>*</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.sonatype.sisu.inject</groupId>
- <artifactId>*</artifactId>
- </exclusion>
- <exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
@@ -448,14 +443,6 @@
<groupId>org.jboss.netty</groupId>
<artifactId>netty</artifactId>
</exclusion>
- <exclusion>
- <groupId>org.codehaus.jackson</groupId>
- <artifactId>*</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.sonatype.sisu.inject</groupId>
- <artifactId>*</artifactId>
- </exclusion>
</exclusions>
</dependency>
<dependency>
@@ -471,14 +458,6 @@
<groupId>org.jboss.netty</groupId>
<artifactId>netty</artifactId>
</exclusion>
- <exclusion>
- <groupId>org.codehaus.jackson</groupId>
- <artifactId>*</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.sonatype.sisu.inject</groupId>
- <artifactId>*</artifactId>
- </exclusion>
</exclusions>
</dependency>
@@ -495,14 +474,6 @@
<groupId>org.jboss.netty</groupId>
<artifactId>netty</artifactId>
</exclusion>
- <exclusion>
- <groupId>org.codehaus.jackson</groupId>
- <artifactId>*</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.sonatype.sisu.inject</groupId>
- <artifactId>*</artifactId>
- </exclusion>
</exclusions>
</dependency>
</dependencies>
View
20 project/SparkBuild.scala
@@ -243,13 +243,11 @@ object SparkBuild extends Build {
val slf4jVersion = "1.7.5"
- val excludeCglib = ExclusionRule(organization = "org.sonatype.sisu.inject")
- val excludeJackson = ExclusionRule(organization = "org.codehaus.jackson")
val excludeNetty = ExclusionRule(organization = "org.jboss.netty")
val excludeAsm = ExclusionRule(organization = "asm")
- val excludeSnappy = ExclusionRule(organization = "org.xerial.snappy")
val excludeCommonsLogging = ExclusionRule(organization = "commons-logging")
val excludeSLF4J = ExclusionRule(organization = "org.slf4j")
+ val excludeScalap = ExclusionRule(organization = "org.scala-lang", artifact = "scalap")
def coreSettings = sharedSettings ++ Seq(
name := "spark-core",
@@ -273,13 +271,13 @@ object SparkBuild extends Build {
"org.spark-project.akka" %% "akka-remote" % "2.2.3-shaded-protobuf" excludeAll(excludeNetty),
"org.spark-project.akka" %% "akka-slf4j" % "2.2.3-shaded-protobuf" excludeAll(excludeNetty),
"org.spark-project.akka" %% "akka-testkit" % "2.2.3-shaded-protobuf" % "test",
- "org.json4s" %% "json4s-jackson" % "3.2.6",
+ "org.json4s" %% "json4s-jackson" % "3.2.6" excludeAll(excludeScalap),
"it.unimi.dsi" % "fastutil" % "6.4.4",
"colt" % "colt" % "1.2.0",
"org.apache.mesos" % "mesos" % "0.13.0",
"net.java.dev.jets3t" % "jets3t" % "0.7.1" excludeAll(excludeCommonsLogging),
"org.apache.derby" % "derby" % "10.4.2.0" % "test",
- "org.apache.hadoop" % hadoopClient % hadoopVersion excludeAll(excludeJackson, excludeNetty, excludeAsm, excludeCglib, excludeCommonsLogging, excludeSLF4J),
+ "org.apache.hadoop" % hadoopClient % hadoopVersion excludeAll(excludeNetty, excludeAsm, excludeCommonsLogging, excludeSLF4J),
"org.apache.curator" % "curator-recipes" % "2.4.0" excludeAll(excludeNetty),
"com.codahale.metrics" % "metrics-core" % "3.0.0",
"com.codahale.metrics" % "metrics-jvm" % "3.0.0",
@@ -316,7 +314,7 @@ object SparkBuild extends Build {
exclude("io.netty", "netty")
exclude("jline","jline")
exclude("org.apache.cassandra.deps", "avro")
- excludeAll(excludeSnappy, excludeCglib, excludeSLF4J)
+ excludeAll(excludeSLF4J)
)
) ++ assemblySettings ++ extraAssemblySettings
@@ -379,10 +377,10 @@ object SparkBuild extends Build {
def yarnEnabledSettings = Seq(
libraryDependencies ++= Seq(
// Exclude rule required for all ?
- "org.apache.hadoop" % hadoopClient % hadoopVersion excludeAll(excludeJackson, excludeNetty, excludeAsm, excludeCglib),
- "org.apache.hadoop" % "hadoop-yarn-api" % hadoopVersion excludeAll(excludeJackson, excludeNetty, excludeAsm, excludeCglib),
- "org.apache.hadoop" % "hadoop-yarn-common" % hadoopVersion excludeAll(excludeJackson, excludeNetty, excludeAsm, excludeCglib),
- "org.apache.hadoop" % "hadoop-yarn-client" % hadoopVersion excludeAll(excludeJackson, excludeNetty, excludeAsm, excludeCglib)
+ "org.apache.hadoop" % hadoopClient % hadoopVersion excludeAll(excludeNetty, excludeAsm),
+ "org.apache.hadoop" % "hadoop-yarn-api" % hadoopVersion excludeAll(excludeNetty, excludeAsm),
+ "org.apache.hadoop" % "hadoop-yarn-common" % hadoopVersion excludeAll(excludeNetty, excludeAsm),
+ "org.apache.hadoop" % "hadoop-yarn-client" % hadoopVersion excludeAll(excludeNetty, excludeAsm)
)
)
@@ -428,7 +426,7 @@ object SparkBuild extends Build {
def flumeSettings() = sharedSettings ++ Seq(
name := "spark-streaming-flume",
libraryDependencies ++= Seq(
- "org.apache.flume" % "flume-ng-sdk" % "1.2.0" % "compile" excludeAll(excludeNetty, excludeSnappy)
+ "org.apache.flume" % "flume-ng-sdk" % "1.2.0" % "compile" excludeAll(excludeNetty)
)
)
View
5 streaming/pom.xml
@@ -56,11 +56,6 @@
<artifactId>jetty-server</artifactId>
</dependency>
<dependency>
- <groupId>org.codehaus.jackson</groupId>
- <artifactId>jackson-mapper-asl</artifactId>
- <version>1.9.11</version>
- </dependency>
- <dependency>
<groupId>org.scala-lang</groupId>
<artifactId>scala-library</artifactId>
</dependency>

0 comments on commit fd31adb

Please sign in to comment.
Something went wrong with that request. Please try again.