Holland Backup Manager
Python Other
soulen3 Python 3 Compatibility, Adding new plugins (#186)
* add mariabackup

Author:    holland

* Correct docs for valid stream types

* WIP: mongodump command

* MongoDB plugin

* Save mongodump stderr to mongodump.log

* Implementing compression

* Minimal documentation

* Added option to copy datadir instead of tar for LVM snapshots.

* 2to3 and get mysqldump plugin working

* Update version number to 1.1.0

* Add fix for #185

* tested xtrabackups, confirmed lib lvm isn't work so added debugging

* mysql_lvm backups work now, but getting trash in the logs
Calling <holland.backup.mysql_lvm.actions.mysql.lock.FlushAndLockMySQLAction object at 0x7fb46d244b70>

* Remove extra debug line

* Add compatibility libs, and get code working on pythong 2.6

* Remove tabs, improve error handling for stop-slave in mysqldump

* Fix to for mk-config

* Fix decoding issue on python2.7

* Holland was exiting cleanly without creating a backup, if stop-slave was yes and slave wasn't running.
Holland will now continue with the backup

* Remove tab from setup.py, make import explicitly import frpm local

* remove tabs

* Update ConfigObj version in README

* Pull read meta data correctly from PKG-INFO in python3

* Fix bugs that broke error handling, and prevented dry-run from working in mysqldump plugin

* fix bug that prevented dry-run from print debug information correctly

* Updates to get dry-run working on EL6

* Last commit broke python3, write bytes in python2 and strings in python3

* Remove maatkit from active plugin list

* Remove mysqlhostcopy from ACTIVE list as it wasn't working in master branch
mysqlhotcopy plugin is mostly working, but the file encoding issue isn't completely solved.

* Update changelog

* Add logging format option

* Print xtrabackup version #166

* Add compatibility lib

* Update MySQL so  bin-log-position work even if stop-slave isn't enabled
Integrate GH pull request 164

* remove tab

* Add mariabackup from #174

* update spec and add compatibility lib

* Fix issue with compression after moving to Python3

* Update spec and CHANGES file

* Update spec and copyright date
Latest commit 4fa1b27 Jun 8, 2018
Permalink
Failed to load latest commit information.
config Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
contrib Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
docs
holland Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
plugins Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
scripts Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
test_config
test_suite/tests/providers/mysqldump/all_databases Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
tests Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
.gitattributes
.gitignore
CHANGES.rst Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
INSTALL correct file paths Feb 9, 2016
LICENSE Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
README Python 3 Compatibility, Adding new plugins (#186) Jun 8, 2018
setup.cfg clipping -dev tag May 9, 2010
setup.py
tomsay.py tomsay: Style cleanups Nov 3, 2016

README

Holland README
==============

Holland is a backup framework that supports multiple
pluggable backup implementations.

LICENSE
=======
holland-core, the basic backup framework is licensed
under the New-BSD ("3-clause") license.  See LICENSE
for more details.

holland-core bundles a few third party libraries
including:
ConfigObj 5.0.6
backports from the python stdlib:
- logging
- subprocess.py
- zipfile.py
- optparse.py

Each of these are under their respective licenses.
Please see LICENSE for more information.