Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Jupyterlab compatibility ? #687

Closed
stonebig opened this issue May 15, 2016 · 19 comments
Closed

Jupyterlab compatibility ? #687

stonebig opened this issue May 15, 2016 · 19 comments
Milestone

Comments

@stonebig
Copy link
Contributor

@stonebig stonebig commented May 15, 2016

is Holoviews (especially widgets) compatible with coming soon Jupyterlab infrastructural change ?

@jbednar
Copy link
Member

@jbednar jbednar commented May 15, 2016

If it isn't, we'll make a version that is compatible.

@philippjfr philippjfr added this to the v1.6.2 milestone Jul 29, 2016
@jlstevens jlstevens modified the milestones: v1.7.0, v1.6.2 Aug 25, 2016
@philippjfr
Copy link
Member

@philippjfr philippjfr commented Nov 15, 2016

Currently this is not properly supported as the widgets fail to display and comms do not work correctly.

@philippjfr
Copy link
Member

@philippjfr philippjfr commented Jan 7, 2017

This will get tackled in our widget code rewrite, which is scheduled for 1.8.

@stonebig
Copy link
Contributor Author

@stonebig stonebig commented Sep 24, 2017

Jupyterlab looks a little bit useless without Holoviews widgets

@stonebig
Copy link
Contributor Author

@stonebig stonebig commented Oct 28, 2017

any hope for coming 1.9.0 ?

@philippjfr
Copy link
Member

@philippjfr philippjfr commented Oct 28, 2017

None unfortunately, we're waiting until bokeh solves Jupyterlab comms issues so we can copy them. We've decided it's not worth getting HoloViews only partially working in JLab.

@athornton
Copy link

@athornton athornton commented Nov 1, 2017

Can you give a pointer to the JL comm issues? I'm interested in at least sniffing out how large a problem it is, and I'd like to get a feel for whether this is something likely to be resolved or whether it is a when-pigs-fly request. We'd obviously prefer to use JupyterLab but if Classic is the only way it's ever gonna work, well, that's worth knowing.

@jbednar
Copy link
Member

@jbednar jbednar commented Nov 1, 2017

Oh, we'll definitely make things work well in JupyterLab, somehow! We're focused on other things for the moment, but there is no option for not supporting JupyterLab.

@rserbitar
Copy link

@rserbitar rserbitar commented Dec 6, 2017

Any plans to add jupyterlab support before their beta release (which is no scheduled for christmas)?

@philippjfr
Copy link
Member

@philippjfr philippjfr commented Dec 18, 2017

@rserbitar Very unlikely unfortunately. We're waiting on bokeh to add support for JupyterLab and that effort appears to have stalled for the time being. I'll try to revisit early next year if there's still been no progress.

@rserbitar
Copy link

@rserbitar rserbitar commented Dec 18, 2017

I thought this was already addressed: bokeh/bokeh#6700

@philippjfr
Copy link
Member

@philippjfr philippjfr commented Dec 18, 2017

Well partially, static plots can be displayed but a lot of the power in HoloViews comes from being able to dynamically update plots, which relies on Jupyter comms. Those do not yet work with bokeh in JupyterLab.

@akhmerov
Copy link

@akhmerov akhmerov commented Feb 19, 2018

@philippjfr aren't holoviews widgets completely separate from the bokeh interaction with jlab?

@rserbitar
Copy link

@rserbitar rserbitar commented Feb 22, 2018

Jupyterlab is in Beta now. Is there an issue on bokeh that corresponds to the features needed to make holoview compatible with jupyterlab? Can anyone point me in the right direction?

@jbednar
Copy link
Member

@jbednar jbednar commented Feb 22, 2018

See #2368 (WIP)

@philippjfr philippjfr modified the milestones: v2.0, v1.10 Feb 27, 2018
@philippjfr
Copy link
Member

@philippjfr philippjfr commented Feb 27, 2018

JupyterLab support now landing in 1.10, we should have a dev release out soon. To try it out on master you can install the extension like so:

conda install -c conda-forge jupyterlab
jupyter labextension install @pyviz/jupyterlab_holoviews

To get DynamicMaps and streams working you will have to wait for bokeh 0.12.15 however.

@philippjfr philippjfr closed this Feb 27, 2018
@stonebig
Copy link
Contributor Author

@stonebig stonebig commented Feb 27, 2018

please make it available on pypi or in a bokeh way style

pip install --pre -i https://pypi.anaconda.org/holoviews/channel/dev/simple holoviews
@stonebig
Copy link
Contributor Author

@stonebig stonebig commented Feb 27, 2018

and don't we need a bokeh dev build too ?

and is "jupyter labextension install @pyviz/jupyterlab_holoviews" final name ?

@jlstevens
Copy link
Contributor

@jlstevens jlstevens commented Feb 27, 2018

and don't we need a bokeh dev build too ?

You will do. The relevant PR isn't even merged yet!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants