Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python3 segfaults in latest version of base image (alpine:3.9) on aarch64 #26

Closed
campbellr opened this Issue Feb 18, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@campbellr
Copy link

campbellr commented Feb 18, 2019

It looks like now that the base images are based on Alpine 3.9, it is causing some issues at keast ibe addon (samccauley/addon-hassiogooglebackup). Specifically, python3 is now segfaulting we attempt to run it.

The previous version of the base image (homeassistant/aarch64-homeassistant-base:20181114, based on Alpine 3.8) seems to work fine.

See also:

@pvizeli

This comment has been minimized.

Copy link
Member

pvizeli commented Feb 19, 2019

you can use our python base images. I think that will fix that. We don't use the python from apk: https://github.com/home-assistant/hassio-base

I close that because they have no effect on Home Assistant. Thanks for reporting

@pvizeli pvizeli closed this Feb 19, 2019

@campbellr

This comment has been minimized.

Copy link
Author

campbellr commented Feb 23, 2019

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.