New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Removing ryobi gdo #17637

Merged
merged 1 commit into from Oct 21, 2018

Conversation

Projects
None yet
7 participants
@guillaume1410
Contributor

guillaume1410 commented Oct 20, 2018

Description:

The component doesn't work anynore. Sadly I have to remove it. Il already removed the code requirement from PyPI

Related issue (if applicable): fixes #

Pull request in home-assistant.io with documentation (if applicable): home-assistant/home-assistant.io#<home-assistant.io PR number goes here>

Example entry for configuration.yaml (if applicable):

Checklist:

  • The code change is tested and works locally.
  • Local tests pass with tox. Your PR cannot be merged unless tests pass

If user exposed functionality or configuration variables are added/changed:

If the code communicates with devices, web services, or third-party tools:

  • New dependencies have been added to the REQUIREMENTS variable (example).
  • New dependencies are only imported inside functions that use them (example).
  • New or updated dependencies have been added to requirements_all.txt by running script/gen_requirements_all.py.
  • New files were added to .coveragerc.

If the code does not interact with devices:

  • Tests have been added to verify that the new code works.
@Danielhiversen

This comment has been minimized.

Member

Danielhiversen commented Oct 20, 2018

Please update the documentation too.
You should also remove it from .coveragerc

@nickovs

This comment has been minimized.

Contributor

nickovs commented Oct 20, 2018

It appears that the py_ryobi_gdo module has disappeared altogether. It would be great if this could get merged ASAP. Currently all PRs other than this one are failing their Travis pylint runs because of the dependency on the no-longer-available py_ryobi_gdo module.

@guillaume1410

This comment has been minimized.

Contributor

guillaume1410 commented Oct 20, 2018

sorry, i think I made a mistake by removing the non working from Pypi too fast :(
@Danielhiversen can you remove it from .coveragerc on your side ? I guess it will be quicker...

@guillaume1410

This comment has been minimized.

Contributor

guillaume1410 commented Oct 20, 2018

@Danielhiversen I don't know if you have seen it but there is the PR #6980 on home-assistant.io for the documentation

cgtobi added a commit to cgtobi/home-assistant that referenced this pull request Oct 20, 2018

@cgtobi

This comment has been minimized.

Contributor

cgtobi commented Oct 21, 2018

@guillaume1410 simply delete line 461 in .coveragerc

@Danielhiversen Danielhiversen merged commit c03b137 into home-assistant:dev Oct 21, 2018

5 checks passed

Hound No violations found. Woof!
WIP ready for review
Details
cla-bot Everyone involved has signed the CLA
continuous-integration/travis-ci/pr The Travis CI build passed
Details
coverage/coveralls Coverage remained the same at 93.605%
Details

@wafflebot wafflebot bot removed the in progress label Oct 21, 2018

@fabaff

This comment has been minimized.

Member

fabaff commented Oct 21, 2018

Breaking change:

The ryobi_gdo cover platform was removed. The dependency which we were using is no longer available.

@balloob balloob referenced this pull request Oct 26, 2018

Merged

0.81 #17809

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment